Free Shipping on All Orders 1-866-764-1801

Vist our Online Store

Search:

Type: Posts; User: g42

Search: Search took 0.00 seconds.

  1. Replies
    95
    Views
    7,413

    Hey, thanks again for all the help. I didn't...

    Hey, thanks again for all the help. I didn't know there was still activity on the thread, the email notifications stopped coming. Anyway, no updates yet, I've been too busy with other things to get...
  2. Replies
    95
    Views
    7,413

    Anybody here know whether Polk's tech support is...

    Anybody here know whether Polk's tech support is useful by email or does it have to be by phone? I just prefer email to phone since during business hours I'm either driving, around noise, and often...
  3. Replies
    95
    Views
    7,413

    Thanks, I might just take you up on that if I...

    Thanks, I might just take you up on that if I can't come up with something local. Won't be right away, I'm horribly busy during the week.
  4. Replies
    95
    Views
    7,413

    I really hope it's something as simple as that,...

    I really hope it's something as simple as that, and by all means, If I've been an idiot I'm willing to admit it. I'll sacrifice my ego to get the music back. But I'm pretty certain I hooked things...
  5. Replies
    95
    Views
    7,413

    I have a multimeter somewhere, given to me but I...

    I have a multimeter somewhere, given to me but I never used it. What exactly do I hook it up to here, and what am I looking for? Also, my equipment was/is plugged into a surge protector. Doesn't...
  6. Replies
    95
    Views
    7,413

    Front speakers were set to small. I tried your...

    Front speakers were set to small. I tried your tip there, hooking up a woofer directly (at low volume) and it immediately worked normally. I didn't try all the woofers, but the one I did try gave...
  7. Replies
    95
    Views
    7,413

    Did a factory reset on the Yamaha, and no change.

    Did a factory reset on the Yamaha, and no change.
  8. Replies
    95
    Views
    7,413

    I hope it's just me being an idiot not doing a...

    I hope it's just me being an idiot not doing a setting or a hookup properly, but I've gone through the settings back to front, inside and out and can't find anything that changes anything. No I did...
  9. Replies
    95
    Views
    7,413

    Thanks for all the suggestions so far. I'll try...

    Thanks for all the suggestions so far. I'll try to address each suggestion:



    I pushed on the woofers GENTLY and they moved freely with no noises or unusual resistance.
  10. Replies
    95
    Views
    7,413

    Thanks for the advice ZLTFUL. Could you please...

    Thanks for the advice ZLTFUL. Could you please explain to me exactly what it is I'm feeling for when I attempt your suggestion? Also, to be fair I was a bit above moderate volume. Not crazy levels...
  11. Replies
    95
    Views
    7,413

    OK I hooked up my rear surrounds (FXI A6s) in the...

    OK I hooked up my rear surrounds (FXI A6s) in the front positions, and they sound normal. I also tried the center channel as the left front, and it sounded normal. But both of these only have...
  12. Replies
    95
    Views
    7,413

    Unfortunately I don't have another receiver or...

    Unfortunately I don't have another receiver or anything else to hook up to the speakers. And I live in the middle of nowhere, with nobody nearby to even borrow from.
  13. Replies
    95
    Views
    7,413

    I unhooked from the Emotiva and put everything...

    I unhooked from the Emotiva and put everything back the way it was. No change. All 4 woofers just do nothing whatsoever.
  14. Replies
    95
    Views
    7,413

    The midrange drivers are working too. Just the...

    The midrange drivers are working too. Just the woofers gone. Just to point out too, I do have a powered sub taking the load off the RTI's woofers.
  15. Replies
    95
    Views
    7,413

    Connector plates are there.

    Connector plates are there.
  16. Replies
    95
    Views
    7,413

    Please tell me my speakers aren't destroyed

    I've had RTI A7s for about a year now, run by a Yamaha RX A810. I also recently added a CSI A6 and FXI A6 rears. The system was never very loud at all so I finally caved in and bought an Emotiva...
Results 1 to 16 of 16