You may have already figured this out, but to make this work on the ps3 you need to go into the sound settings and choose "optical out". When you choose this it no longer outputs sound over the hdmi...