Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    Past Area 51
    Posts
    85

    Default DSW PRO 660wi-Need Help With Settings

    Hi, just purchased a Polk DSW PRO 660wi (hard wired with rca cable to LFE input from sub out). What would be the recommended frequency for the setting on my Onkyo TX-NR808 receiver (used as pre/amp)? If I set it manually, I can go with 25hz, 40hz, 63hz, 100hz and 160hz (this is what the receiver allows). Also, there's a knob on the back of the subwoofer which has LOW PASS 60hz -110hz -160hz, I don't understand. If I set up the receiver with one setting, does the knob on the back of sub overide it. Also, I am Using the subwoofer as LFE (switch is to yes). Any recommendations on the settings or perhaps not using it as LFE would be appreciated. Thanks, Tavo

  2. #2

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    Subwoofer LOW PASS knob, all the way up.

    AVR setting to either 100 or 63hz, depending on what sounds better to you. I'd probably go with 63hz if you have floorstanders, 100hz is you have bookends your Left & Right loudspeakers.

    When set to Subwoofer YES, the AVR handles the subwoofer xover. Use this method.
    Last edited by dorokusai; 01-04-2011 at 12:12 AM.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    Past Area 51
    Posts
    85

    Default

    I read in the manual that the LOW PASS knob becomes disabled when you run the RCA cable from sub-out to the LFE input of the sub. The settings are managed by the receiver setup option. I can only go as low as 80Hz and as high as 120Hz on the receiver settings for the subwoofer. Any idea why?

  4. #4

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    Mobile, AL
    Posts
    3,269

    Default

    Quote Originally Posted by tavogee View Post
    I read in the manual that the LOW PASS knob becomes disabled when you run the RCA cable from sub-out to the LFE input of the sub. The settings are managed by the receiver setup option. I can only go as low as 80Hz and as high as 120Hz on the receiver settings for the subwoofer. Any idea why?
    Check the other thread. I answered this in detail.
    Equipment list:
    Onkyo TX-NR3010 9.2 AVR
    Emotiva XPA-3 amp
    Polk RTi70 mains, CSi40 center, RTi38 surrounds, RTi28 rears and heights
    SVS 20-39CS+ subwoofer powered by Crown XLS1500
    Oppo BDP-93 Blu-ray player
    DarbeeVision DVP5000 video processor
    Epson 8500UB 1080p projector
    Elite Screens Sable 120" CineWhite screen

  5. #5

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    Past Area 51
    Posts
    85

    Default

    Thanks kuntasensei!

  6. #6

    Member Sales Rating: (0)

    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    194

    Default

    Thanks again for the info by kuntasensei. I read the thread and set my avr to the threads directions. All is working ok. No need to look any further.
    Onkyo TX-NR807
    polkaudio RTiA5
    polkaudio CSi A6
    polkaudio RTiA3
    B&K ST.3140 Power Amplifier
    HSU Research VTF2 MK3
    Vizio E472VL
    Panasonic 605 blu ray
    Onkyo DS-A4 i-pod Dock
    Universal Remote
    BDI Icon 9429 TV Stand

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help DSW PRO 660wi Subwoofer
    By tavogee in forum Forum Testing Area
    Replies: 7
    Last Post: 01-05-2011, 09:01 AM
  2. PS3 settings
    By bsturgeon89 in forum Electronics
    Replies: 16
    Last Post: 08-02-2010, 11:58 PM
  3. What's the best the settings?
    By bigones in forum Subwoofer Hookup & Bass Management
    Replies: 6
    Last Post: 12-13-2009, 10:24 AM
  4. Amp Settings
    By JoshParsons84 in forum Car Audio & Electronics
    Replies: 1
    Last Post: 11-24-2008, 12:39 AM
  5. Not sure about settings with DSW Pro 600 and RTi A7s
    By targac5 in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 01-16-2008, 11:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts