Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (1)

    Join Date
    Jun 2002
    Posts
    3,860

    Default Help Luxman R 115!!!

    i hooked it up to my rti150s and it sounded very quiet, and mostly in the right channel then when i turn it up the amp shuts down and doesnt power back up until i turn it up again...i plugged the speakers into the B terminals and it works fine, there are two seperate amps for each A and B so i think the A amp is dead? what u guys think? IM me on Airplay355 if u would rather talk to me that way, instead of posting and waiting 10 minutes. thanks
    SDA 2B
    Carver m0.5t
    AMC pre
    Cobalt Cables

  2. #2

    Member Sales Rating: (27)

    Join Date
    Mar 2003
    Location
    NC
    Posts
    20,952

    Default

    Sounds to either........

    1) needs the terminals/inputs/outputs cleaned

    or......

    2) the soldering needs to be redone
    www.Vr3Mods.com ///// www.Version3Audio.com

    "No, that's silly talk. Dude, you can't possibly be this audio dumb so quit the act." - Doro

  3. #3

    Member Sales Rating: (1)

    Join Date
    Jun 2002
    Posts
    3,860

    Default

    things work fine now...this goddam receiver drives me crazy, it works whenever it decides its necessary. very strange
    SDA 2B
    Carver m0.5t
    AMC pre
    Cobalt Cables

  4. #4

    Member Sales Rating: (0)

    Join Date
    Aug 2009
    Posts
    1

    Default

    anyone know where to get a copy of owners manual for luxman r-115?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts