Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2003
    Posts
    2

    Default My sub plays everything

    Hey Im still new at this and i installed two 10s to a 2 channel amp and im running RCA cables to the radio. the problem is my sub plays everything, voices, treble, etc. and i cant figure out how to stop it. Please help me out, is there something i can hook up to cut out everything but the bass. I have a Legacy 240w 2 channel amp. thanks.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    well you have two problems...

    1- you paid money for a legacy amp -- thats like buying a sack of magic beans.

    2- you need to utilize a crossover (low pass filter) to only allow the bass to run to the sub.

    you can fix the crossover problem in a few ways...

    a) if the amp has a built in crossover, engage it, turn it to "low pass" or "LP" and if it has a dial for the setting, set it to about 90 hertz.

    b) if the head unit (radio) has a built in electronic crossover for its pre-amp outputs then you can engage it there, and set to low pass... anything between 80 and 100 hertz should do.

    c) if you have no crossovers at all then you can either spend 20 bucks on a set of Harrison Lab's FMOD inline RCA crossovers or you can get a simple subwoofer crossover network from crutchfield for about 30 dollars that will hook inline with hte RCA's and hack out all but the bass. this is the better choice since then u can have more options than with the Fmods (no options at all - preset).

    d) since you're running under 35 volts AC parts are easy to find and you can build your own crossover network, but i really would not advise it for you... besides, now that i think of it, it may be a bitch to get low pass stuff for 100 hz. high pass is cake but low might be a bizzzatch. i'm too tired to really think about it tht much. but try to do a/b/c ... those are u best bets.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jul 2003
    Posts
    2

    Default

    if i got an Fmod, what hz level should i get. I wanna make this as simple as possible as i currently don't know too much about these settings and am prone to causing damage. thanks

  4. #4

    Member Sales Rating: (0)

    Join Date
    Aug 2002
    Location
    Buffalo, NY
    Posts
    3,962

    Default

    well 85 hertz would be the goal but i think they jump from 75 up to 100...

    are u sure the amp doesn't have a built in sub crossover?

    check... look hard... if u're 100% sure u cant fix it with what you've got, post back and i'll find you something 'simple' and in the 30 dollar range to solve the problem.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts