Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    DFW
    Posts
    68

    Default New Amp, Speakers Buzzing???

    Just got a Rotel RMB-1095!!!! Hooked it up lastnight and it sounded great during a movie and some cds. but when i have nothing playing i can hear a slight buzzing sound from all speakers..... it does get worse when i have all the lights turned on in my room and does not completely go away when i turn them off. whats going on here?? thanks in advance
    My setup:
    58" Samsung C7000 plasma
    Pioneer VSX 1120-k
    Sony BDP 770 b-ray
    ROTEL RMB 1095
    ROTEL RB 1090
    Black Mamba II intc.
    RTi A9 (pair)
    CSi A6
    FXi A6 (pair)
    DSW PRO 550wi

  2. #2

    Member Sales Rating: (47)

    Join Date
    May 2005
    Location
    Sufficiently Breathless
    Posts
    11,095

    Default

    try using a cheater plug(two pronged ) or disconnect your CATV from you pre-processor and see if that helps.
    JC approves....he told me so. (F-1 nut)

  3. #3

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    chicago
    Posts
    16,024

    Default

    Ground loop, cheater plug is the easiest,cheapest fix, or most likely the cable box like George said.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    DFW
    Posts
    68

    Default

    tired unpugging everything except the amp and still ahve the buzzing. bypassed the surge protecter and even switched to a different outlet and still have the buzzing (not quite as bad)
    My setup:
    58" Samsung C7000 plasma
    Pioneer VSX 1120-k
    Sony BDP 770 b-ray
    ROTEL RMB 1095
    ROTEL RB 1090
    Black Mamba II intc.
    RTi A9 (pair)
    CSi A6
    FXi A6 (pair)
    DSW PRO 550wi

  5. #5

    Member Sales Rating: (7)

    Join Date
    Oct 2009
    Location
    Katy, TX
    Posts
    1,392

    Default

    In my case it was a pair of IC's. Unplug them one pair by one pair to see if you can identify the source of buzz. I did that, replaced that pair, and the buzzing went away completely.
    Gears shared to both living room & bedroom:
    Integra DHC-80.3 / Oppo BDP-105 / DirecTV HR24 DVR /APC S15blk PC-UPS
    Living room:
    LSiM707's / LSiM706c / LSiM702 F/X's / dual JL Audio Fathom F113's / Parasound Halo A51 / Panasonic 65" TC-P65VT50
    Bedroom:
    Usher Dancer Mini 2 Diamond DMD's / Logitech SB Touch / W4S STP-SE / W4S DAC-2 / W4S ST-1000 / Samsung 52" LN52B750
    Other rooms:
    Audioengine AP4's / GLOW Audio Sub One / audio-gd NFB-3 DAC / Audioengine N22
    audio-gd NFB-10.2 / Denon AH-D7000

  6. #6

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    DFW
    Posts
    68

    Default

    ok, took ikt one more step.. bought a cheater plug, didnt work. disconnected all interconnects. still buzzing. it has to be the amp for something with my house....my electrical
    My setup:
    58" Samsung C7000 plasma
    Pioneer VSX 1120-k
    Sony BDP 770 b-ray
    ROTEL RMB 1095
    ROTEL RB 1090
    Black Mamba II intc.
    RTi A9 (pair)
    CSi A6
    FXi A6 (pair)
    DSW PRO 550wi

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Posts
    276

    Default

    I had the same thing with my acurus amp, it was a ground loop issue with the catv coax. I had a power strip that was grounded and ran the coax in/out of the power strip and it solved the issue...

    If you still have buzzing when all the interconnections are disconnected, make sure that the power transisters/blocks...like an xbox 360 or others are unplugged also. this may cause buzzing. Buzzing usually is not the amp but the ground or some type of electrical interfearence
    Harman kardon signature 2.1 amp
    Denon 3312
    Epson 8700ub
    Chief mount
    Screen Innovations Performance Series 110in
    Kef q 500 (RL)
    Kef q 200 (C)
    Kef q 800 (Rear RL)
    REL T7 (SUB)
    mx 450 remote
    Sonos-Amp, Connect, Play5

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Buzzing/noise from speakers
    By gte697h in forum Troubleshooting
    Replies: 7
    Last Post: 06-24-2008, 01:34 PM
  2. Buzzing or Humming Speakers Help!
    By lschweigman in forum Troubleshooting
    Replies: 9
    Last Post: 05-17-2007, 10:01 PM
  3. buzzing sound on speakers SDA-CRS
    By egp823 in forum Troubleshooting
    Replies: 23
    Last Post: 10-26-2004, 10:56 PM
  4. speakers are buzzing
    By cr_buck in forum Troubleshooting
    Replies: 1
    Last Post: 05-31-2002, 10:50 PM
  5. speakers are buzzing
    By cr_buck in forum Troubleshooting
    Replies: 2
    Last Post: 05-31-2002, 09:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts