Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2004
    Location
    Long Island, NY
    Posts
    19

    Default PSW-202 is now making a hum when plugged in...

    It seems after reading a ton of posts over the years about powered subs developing a hum, my PSW-202 has joined the club! Out of nowhere last nite, I turned the system on to watch a movie, and there was a loud hum coming from the sub. It is not effected by unplugging the source cable, and only goes away when the sub is actually switched to off. After reading, it seems they all have the same issue, mine just lasted a lot longer then most. It stills plays audio, and the hum, but I unplugged it as to not damage the driver. I called to get the repair info, but I guess I am going to be subless for a while as I have to save the money to send it in. Being laid off, I have actually had a bit more time to catch up on movies, but I guess now they'll be subless.....


    Sean

  2. #2

    Member Sales Rating: (5)

    Join Date
    Mar 2009
    Location
    Richardson, TX.
    Posts
    1,523

    Default

    A loud hum is probably just a bad power supply cap. How handy are you with a screwdriver and soldering iron?
    Are you part of the dirty digital peasants or a member of the great Analog Master Race?

    SDA Recommended Playlist https://docs.google.com/spreadsheet/...FZCRkdxYXVNanc

    Open for editing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Subwoofer static, boom when plugged in
    By mudixon in forum Troubleshooting
    Replies: 17
    Last Post: 09-01-2009, 11:28 AM
  2. Do you leave your small appliances plugged in 24/7?
    By Ron-P in forum The Clubhouse
    Replies: 47
    Last Post: 10-29-2008, 05:33 PM
  3. problem with amp plugged into receiver switched outlet??
    By AsSiMiLaTeD in forum Electronics
    Replies: 14
    Last Post: 04-03-2004, 01:09 AM
  4. Stereo Plugged Back Up! FINALLY!
    By VR3 in forum The Clubhouse
    Replies: 2
    Last Post: 01-01-2004, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts