Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2007
    Posts
    5

    Default Help with settings

    Hello all,

    I currently having Polk Rti8's as my fronts, a Csi3 for the center, R150's for surrounds and the PSW110 for my sub. I recently hooked a Sony DH-810 to them and was wondering if my current settings are the best for what I have.

    I went through the auto calibration, but had to make some adjustments and here is where I'm at right now.

    The Front/Center channels are set to SMALL.
    The Front/Center crossovers are set to 80hz.
    The Surround crossovers are set to 120hz.
    The sub is turned up halfway, and set at about 120 - 130 hz and a 0 degree phase.

    The Polk Rti8s are also biamped and biamp also set on the receiver as well.

    I will say I watched Master and Commanders opening scene and it sounded fantastic.. I then watched some of PoTC: Curse of the Black Pearl and the sound seemed a bit lacking. Surrounds didn't seem lively or being used much. Perhaps this is just the audio mixing on the BluRays themselves.

    Any suggestions or tweaks I could make, or something that isn't quite right or I need to check?

    Thank you.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Mar 2010
    Posts
    750

    Default

    your settings are fine. except set the sub to the max hz and use 1 LFE connector. make sure you turn off all the sound effects from your AVR

  3. #3

    Member Sales Rating: (0)

    Join Date
    Feb 2010
    Location
    Lansing, MI
    Posts
    18

    Default

    Were you able to manually change the soundtrack on Pirates to PCM? I believe that disc defaults to DD 5.1 (at least that's what mine does).
    AUDIO - Fronts: Polk Audio RTI A9's | Center: Polk Audio CSI A6 | Sides: Polk Audio FXi A4's | Sub: HSU STF-1 | Receiver: Yamaha RX-V663 w/ AQ Type-4s | Amp: Rain MM-6 (300W x3)| Power: Panamax M5300-PM

    VIDEO - Epson Powerlite 8350 Projector on Elite Electric100H Screen | Panasonic TH-42PX60U | Panasonic DMP-BD35 | Toshiba HD-A2

  4. #4

    Member Sales Rating: (0)

    Join Date
    May 2007
    Posts
    5

    Default

    Quote Originally Posted by alienwatcher View Post
    Were you able to manually change the soundtrack on Pirates to PCM? I believe that disc defaults to DD 5.1 (at least that's what mine does).
    I checked this half way through and set it to PCM. Sounds much better. Thank you.

    your settings are fine. except set the sub to the max hz and use 1 LFE connector.
    Right now I have a sub cable running to the sub then i use a splitter to hook into the Left and Right line in jacks. Are you saying to only hook into one? Thank you.
    Last edited by blobula; 04-12-2011 at 07:25 PM. Reason: Edt

  5. #5

    Member Sales Rating: (0)

    Join Date
    Feb 2010
    Location
    Lansing, MI
    Posts
    18

    Default

    You can use both input jacks on the sub. Sometimes it helps eliminate potential issues in the chain by simplifying things. However I know many people that swear by using both input jacks depending on the sub and cables being used. I've never heard of anyone breaking their sub by using both jacks either. I say if it sounds good, do it!

  6. #6

    Member Sales Rating: (0)

    Join Date
    Mar 2010
    Posts
    750

    Default

    there is no reason to add another component/cable to the system when not needed. the sub will see the same mono signal anyway, not like there is a L and R signal from your AVR.
    Just use 1 input(R or L depends on your sub). on the sub there should be a switch to set to LFE.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Settings help
    By LandShark in forum Electronics
    Replies: 3
    Last Post: 08-29-2010, 01:28 PM
  2. Psw 505 settings
    By Marlboro_Man in forum Subwoofer Hookup & Bass Management
    Replies: 5
    Last Post: 03-05-2009, 08:06 AM
  3. RTi A5 EQ settings
    By bevo in forum Speakers
    Replies: 5
    Last Post: 02-21-2009, 08:31 AM
  4. Not sure about settings with DSW Pro 600 and RTi A7s
    By targac5 in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 01-16-2008, 11:27 PM
  5. Sub settings
    By Lono in forum Subwoofer Hookup & Bass Management
    Replies: 6
    Last Post: 05-06-2003, 11:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts