Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2

Thread: Psw111 feedback

  1. #1

    Member Sales Rating: (0)

    Join Date
    Nov 2011
    Posts
    1

    Default Psw111 feedback

    I just bought a new psw111 sub and I am using an RCA with the LFE out and I'm getting horrible feedback like a wind noise and can't get rid of it. Anyone got any help? Thanks!

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jan 2011
    Location
    Nebraska
    Posts
    1,622

    Default

    Sounds like you have a ground loop problem. What kind of RCA cable are you using? Is it laying next to any power wires?
    AVR: Onkyo Tx-NR808
    Amplifier: Carver A-753x 250 watts x 3
    Fronts: Polk RTI A7 (modded by Trey VR3)
    Center: CSI A4 (modded by Trey VR3)
    Rear: FXI A4
    Sub: Polk DSW Pro 660wi
    TV: LG Infinia 50PX950 3D
    Speaker Cable: AudioQuest Type 8
    IC: AudioQuest Black Mamba II

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. PSW111 Set Up Help
    By Evanguy2004 in forum Subwoofer Hookup & Bass Management
    Replies: 4
    Last Post: 03-04-2011, 09:45 PM
  2. Need Help Psw111
    By tshepball in forum Troubleshooting
    Replies: 8
    Last Post: 12-31-2009, 01:54 PM
  3. Psw111
    By Fud in forum Troubleshooting
    Replies: 10
    Last Post: 08-31-2009, 09:05 AM
  4. Need Help better sub psw111 or 110
    By forgiven814 in forum Subwoofer Hookup & Bass Management
    Replies: 8
    Last Post: 10-09-2008, 10:49 PM
  5. Tutorial For Leaving Feedback Using the New iTrader Feedback System
    By BaggedLancer in forum For Sale (FS) Classifieds
    Replies: 0
    Last Post: 02-24-2008, 08:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts