Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2013
    Posts
    26

    Unhappy subwoofer huming

    Hi guys I recently bought a submersive that started humming as soon as I plug it into a wall outlet.The thing is if I plug it into a surge protector,the huming is minimal to the point of me having to push my ears to it to hear anything.When I plug it into the wall outlet,the huming will increase/decrease with the gain button.I tried posting on the seatonforum but it's hard getting any input there even through email.

    Is this a hum I should worry about?Could it be a defective amp?I can't even use my sub right now because I'm worried,any input would be great guys.You think the support would be better when your paying that much for a sub-(

  2. #2

    Member Sales Rating: (55)

    Join Date
    Jul 2001
    Location
    Exit 5 on the Jersey Turnpike
    Posts
    11,965

    Default

    Try using a cheater plug at the end of the sub's power cord. If it has a two-prong, use a three-prong cheater. If it has a three-prong, use a two-prong cheater.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jul 2013
    Posts
    26

    Default

    thanks george,I will have to grab one as soon as the ice storm settles down lol.In the meanwhile you think I should be able to use the sub or no?

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2012
    Location
    Cleveland, Ohio
    Posts
    321

    Default

    Does it hum with the signal interconnect cable/s removed?
    Is it plugged into the same AC wall outlet as the rest of the system?

  5. #5

    Member Sales Rating: (0)

    Join Date
    Jul 2013
    Posts
    26

    Default

    Quote Originally Posted by Speedskater View Post
    Does it hum with the signal interconnect cable/s removed?
    Is it plugged into the same AC wall outlet as the rest of the system?
    No the humming is totally gone with the cable removed BUT while the cable is connected,changing from the powerbar to the wall outlet will cause the humming to get louder.I'm just worry that is can affect/damage the amp somehow.

  6. #6

    Member Sales Rating: (0)

    Join Date
    Dec 2012
    Location
    Cleveland, Ohio
    Posts
    321

    Default

    Do you have any signal cables from cable TV or satellite TV or internet or audio systems in other rooms connected?

    If all else fails:

    Name:  AP ground wire.png
Views: 38
Size:  74.0 KB

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Adding wireless subwoofer to existing 2 subwoofer system
    By rrsjls@msn.com in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 08-08-2012, 01:33 PM
  2. Wanted Subwoofer.....
    By shawn474 in forum Wanted (WTB) Classifieds
    Replies: 2
    Last Post: 06-26-2011, 10:11 PM
  3. Replies: 22
    Last Post: 08-08-2009, 10:53 PM
  4. I need a FET for PSW 120 subwoofer
    By Don Piano in forum Subwoofer Hookup & Bass Management
    Replies: 3
    Last Post: 01-11-2008, 08:01 PM
  5. Subwoofer
    By criverajr in forum Flea Market
    Replies: 1
    Last Post: 05-09-2005, 03:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts