Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Feb 2012
    Posts
    2

    Smile PSW10 blows fuse upon connection to mains even when Power Switch is 'Off'

    Hi All -

    Newbie here to the Forums.

    Back in the day (1960's) I was a respectable electronics tech but things have changed and to boot I'm in a new area - troubleshooting a PSW10 when I thought I would be listening to it.

    When I plug it in it blows the fuse even though there's no audio present and the Power Switch is set to 'Off'.

    The fuse blows so quickly that I can't find out where the short is.

    I got as far as in-curcuit testing the 4700 ufd electrolytics on the PC board. The one closer to the rectifier bridge reads 4.0 Ohms both ways and the other one reads 6.9 Ohms both ways so I'm suspicious but without a schematic or a troubleshooting guide I'm loath to dig in further to reverse engineer it.

    Can you help me?

    Thanks!

    Bill

  2. #2
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,845

    Default

    Hello Bill,
    It's probably best to contact Polk's CS department at 1-800-377-7655 or email at polkcs@polkaudio.com. They can determine if you are covered by the amp's three year warranty or not. They'll need to know when and where the sub was purchased. They can also help with non-warranty amp repairs, schematics, etc.
    Regards, Ken

  3. #3

    Member Sales Rating: (4)

    Join Date
    Feb 2007
    Posts
    6,974

    Default

    +1

    Polk Customer Service is great and I am sure they will set you straight!
    polkaudio RT35 Bookshelves
    polkaudio 255c-RT Inwalls
    polkaudio DSWPro550WI
    polkaudio XRT12 XM Tuner
    polkaudio RM6750 5.1

    Front projection, 2 channel, car audio... life is good!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. PSW10 - Blown Fuse
    By Taustin in forum Subwoofer Hookup & Bass Management
    Replies: 10
    Last Post: 08-16-2013, 11:59 AM
  2. Need Help PSW10 No Power - Fuse Location?
    By apothacarion in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 08-14-2010, 10:42 PM
  3. Need Help PSW350 No Power & Blows Fuse
    By snafu2dj in forum Troubleshooting
    Replies: 2
    Last Post: 12-22-2009, 03:06 AM
  4. Replies: 1
    Last Post: 01-08-2008, 03:44 PM
  5. no power to sub so replaced the fuse and the fuse kept on blowing?????
    By newbie2k8 in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 01-08-2008, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts