Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    5

    Unhappy Monitor 10b - tweeter working but that's it

    Hi
    My lovely wife decided to remodel the living room while I was not home, moved the Polk Monitor 10b's, now when I hook them back up on one of them only the tweeter is working (no bass or mids). Checked the same connection by swapping speakers and the other one is fine. Not sure what to do next, have read other threads about frozen drivers when the speaker gets dropped (which she swears it wasn't, but....), would both mids and the woofer all go out at the same time for any other reason?

    Can anyone give me some steps to do to diagnose this? (I'm not a speaker expert so keep that in mind)
    If I need repairs, is it difficult to find parts or someone knowledgeable to do the work? Or is it easier trying to find something on Craigslist to replace and not bother with repairs? (Or give up and get an new set of speakers).

    I've had these for 20 years (bought them used) and love their sound, but maybe it's time to move on(?)

    Any advice would be welcome. Thanks!!

  2. #2

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,232

    Default

    Ok, first thing....that's not a woofer, it's a passive radiator meaning there are no electrical connections to it. So with that out of the way, get a Philips screwdriver and remove the passive radiator. Once the PR is removed you'll be able look around inside the cabinet. Check for a loose connection(s) at the crossover and the mid-drivers.

    Just thought of something else. Do you any fuses on the binding post plate?
    Last edited by F1nut; 03-25-2012 at 12:33 AM.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  3. #3

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    5

    Default

    F1nut:
    Thanks for your reply. Good to know about the passive radiator - like I said, no expert, just know what sounds good!! I will check out the connections per your note. I do not have any fuses on the binding post plate on this model, just the binding posts and red and black tightening nuts.
    I'll post again after checking the connections. Thanks.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    5

    Default

    F1nut
    All connections look fine to both of the drivers and the xover.

    Any other ideas?

    Thanks

  5. #5

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,232

    Default

    Ok then try this, using your fingers spread out evenly around the cone area and with even pressure move the cones back and forth. Do they move? Do you hear any scraping noise?
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  6. #6

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    5

    Default

    F1nut
    The cones move some, but not as freely as the speaker that is still working. Have to use more pressure to get them to move, and there isn't nearly the in/out movement in comparison. I don't hear any scraping noises. Both cones are about the same in terms of movement. Thanks.

  7. #7

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,232

    Default

    It would seem you have two bad drivers. One last thing, swap the two suspected bad drivers with the known good ones. If the suspected bad ones do not work in the other cabinet you know for sure it's the drivers. There is a part number, MWxxxx on the back. Call Polk to order new ones and give the bill to your lovely wife.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  8. #8

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Location
    Central NC
    Posts
    2,526

    Default

    And tell them you're a member of Club Polk here for free shipping and a discount.
    "Science is suppose to explain observations not dismiss them as impossible" - Norm on AA; 2.3TL's w/sonicaps/mills, polyswitches removed, Lg Solen inductors, RD-0198's, MW's dynamatted, Armaflex speaker gaskets, H-nuts, brass spikes, Cardas CCGR BP's, upgraded IC Cable, Black Hole Damping Sheet strips installed on back wall behind MW's & Tweeters, interior of cabinets sealed, AI-1 interface with 1000VA A-L transformer

  9. #9

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    5

    Default

    F1nut
    Just swapped out the bad drivers in the good speaker, they don't work there either so you are correct, the drivers are bad (not the xovers). I will call Polk tomorrow and try to get the drivers ordered (and ask for the discount and free shipping!!). And yes, I'll give the bill to the lovely wife (though I end up paying for it anyway)! Thanks for all your help, I really do appreciate it. And I learned a lot about my speakers to boot (and so did my son)!
    Frank

  10. #10

    Member Sales Rating: (0)

    Join Date
    May 2011
    Location
    Baltimore
    Posts
    8

    Default

    Keep in mind when installing the replacement drivers that on the older Monitor series speakers, on the internal leads to the drivers the BLACK wire is Positive (+) and the WHITE wire is negative (-). This is the reverse of what is typical. Accidentally mixing these up will result in your speakers being out of phase with each other. Otherwise the driver change is a snap.
    Justin Dorsey
    www.Soundscapemd.com
    (we were the first polkaudio dealer ever)
    ___________________________
    Pioneer 880PRS
    Polk SR6500/5250
    SR104dvc
    C400.4-modded/C500.1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Non working tweeter in Monitor 7 series 2
    By tubezrock in forum Troubleshooting
    Replies: 20
    Last Post: 10-29-2011, 05:29 AM
  2. lsi 15 tweeter not working
    By slammerag03 in forum Troubleshooting
    Replies: 16
    Last Post: 02-11-2010, 09:42 AM
  3. Tweeter in Monitor 50's not working.
    By rveenstra in forum Troubleshooting
    Replies: 7
    Last Post: 12-28-2008, 01:16 PM
  4. Need Help SDA 1 Tweeter not working
    By derek_murray in forum Troubleshooting
    Replies: 5
    Last Post: 10-05-2008, 01:15 PM
  5. Help with non working tweeter in rt-8
    By Orange_Crush in forum Troubleshooting
    Replies: 1
    Last Post: 06-04-2007, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts