Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    2

    Default Buzzing sound coming from speakers

    I have the Polk rm75 5.1 speaker set combined with a yamaha rx-v571 receiver and a Polk pw10 sub. After about 5 days the center and left channel speakers started putting out a loud buzzing sound. This only happens when BOTH wires are plugged in and it doesn't matter which side (+ or -) the wires are in. I have tried new wire and tried changing the connection at the receiver itsel but I still get the buzzing sound. It happens immediately after the receiver is turned on. Not reallysure what to do and Polk support is only open mon-fri.

  2. #2

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,301

    Default

    Swap the right channel speaker with the left channel speaker. If the buzzing still comes from the left channel, your AVR has a problem. If the buzzing moves to the right channel, your speaker has a problem.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  3. #3

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Posts
    2

    Default

    Quote Originally Posted by F1nut View Post
    Swap the right channel speaker with the left channel speaker. If the buzzing still comes from the left channel, your AVR has a problem. If the buzzing moves to the right channel, your speaker has a problem.
    Thanks for the reply. I tried a different speaker and am still getting the buzzing sound. It sounds like it is picking up a radio station but isn't quite at the correct frequency b/c I can hear songs playing but it is too quiet (even when the volume is way up) to make out. Am I still looking at an issue with the receiver?

  4. #4

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,301

    Default

    I believe so. Any chance you can borrow an AVR from a friend?
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  5. #5

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    chicago
    Posts
    17,128

    Default

    Could be a variety of things really. Are you using shielded cables ? I would first disconnect the subwoofer cable from the receiver and see if that helps at all. Also, are the wires on a carpeted floor ? If you have wool carpet, those are terrible for static. Another thing you can try is just move the avr and 2 speakers to another room and see if you get the same buzzing. If not, then at least you know it's not the avr and may have to do with cables, static, ground loop, or the outlets.

    I'm alittle confused when you say it only happens when both wires are plugged in. They should be...always. Positive to positive, negative to negative.

  6. #6

    Member Sales Rating: (18)

    Join Date
    Mar 2004
    Location
    Ottawa
    Posts
    7,398

    Default

    Maybe there is a Bee in the speaker?

    I would agree with tony sounds like your cables are not shielded or shielded enough.
    HT- HK 335, Rotel 1075, Miova PC, AQ Indigo Speaker Cable, XLO Jumpers, AQ Diamondback ICs, AQ HDMI x2, AQ Component, Signal Cable Analog II ICs, Signal Cable Digcoax, Signal Cable Toslink, Rti8, Csi5, Rti6, Energy s10.2, Panny 42" Plasma, PS3, Harmony 1100 and Harmony PS3 Adapter, LG dvdp(for the kids), Monster 3600MKII all on a dedicated circuit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. hissing sound coming from speakers
    By Flash! in forum Basic Hookup/Wiring Questions
    Replies: 9
    Last Post: 02-25-2009, 12:13 AM
  2. Buzzing coming from Velodyne CHT-12 amp
    By BjornB17 in forum Speakers
    Replies: 12
    Last Post: 01-23-2006, 10:24 PM
  3. buzzing noise coming from rear speaker
    By gools in forum 2 Channel Audio
    Replies: 4
    Last Post: 11-26-2005, 03:30 PM
  4. buzzing sound on speakers SDA-CRS
    By egp823 in forum Troubleshooting
    Replies: 23
    Last Post: 10-26-2004, 10:56 PM
  5. Buzzing Sound
    By nitro37 in forum Troubleshooting
    Replies: 1
    Last Post: 06-23-2004, 04:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts