Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    Laker City (LA), CA
    Posts
    1,071

    Default SR Tweeter Blown? How to be sure...

    So basically a month or so after i had everything playing - im driving with the radio on at VERY low listening levels.
    When i say very low, i mean - i was in the car with my father and brother and had lowered the volume because we were talking....
    Anyways, i hear a tiny pop. Aww crap. Power down the radio... lame
    So later that day, i turn it on and i hear highs only coming from 1 location.
    Turn it off again.
    Next time im in the car on my way to work, radio off.
    Pop...

    WHAT THE EFFFFFFF :(

    So since then i havent tried to listen to it. I took my fuse out and figured i would wait till i had time to check it all out.

    I am running active with a ms-8 controlling it all. No crossovers (this may have been the problem, but with the ms-8 it shouldnt be). See my Sig for the equipment.

    mids were fine last time.
    2013 Toyota Prius
    Audible Physics 3 Way: H6MB, AR3-A, AR2.0
    Image Dynamics iDMax 12" D2v4
    (2) Alpine PDX-V9 Bridged, Alpine PDX-M12 (500w Mid-Bass, 200w Mid, 200w Tweet, 1200w Sub)
    Mosconi 6to8 v8

  2. #2

    Member Sales Rating: (0)

    Join Date
    Oct 2004
    Location
    North Texas
    Posts
    6,140

    Default

    I have nothing to offer, but I hope you get it figured out. I'm really hoping you didn't blow the tweeters. I was talking to my wife about it and told her how sad it made me and she actually was a little sad herself. Those are the speakers that threw me head-long into 2 channel.
    Usher CP-6311, Shuguang S200MK, Shuguang S845MK, Pioneer BDP-51fd, Essence Audio HDACC, Douglas IC's, Douglas Alpha bi-wire SC's, Pangea/Douglas PC's, Epson 8100

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    Laker City (LA), CA
    Posts
    1,071

    Default

    They aren't blown. I connected the fuse again, pulled all the fuses on the amps, popped them back in and they fired up.

    Right now just the driver side woofer isn't playing, which very well could be the connector slipping lose.

    When i get settled and finish up this move im gonna finish the system.

    I swear, DONT EVER CONNECT EVERYTHING UNTIL EVERYTHING IS DONE, or you will never finish.

    My build is 90% done and because i have sound i didnt work on it anymore. GRRRRRRRR
    2013 Toyota Prius
    Audible Physics 3 Way: H6MB, AR3-A, AR2.0
    Image Dynamics iDMax 12" D2v4
    (2) Alpine PDX-V9 Bridged, Alpine PDX-M12 (500w Mid-Bass, 200w Mid, 200w Tweet, 1200w Sub)
    Mosconi 6to8 v8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. tweeter blown
    By jstplynya in forum Wanted (WTB) Classifieds
    Replies: 1
    Last Post: 09-15-2007, 03:04 PM
  2. RT 55 Blown Tweeter & What else???
    By mrvespa in forum Troubleshooting
    Replies: 4
    Last Post: 11-06-2006, 07:50 AM
  3. Blown tweeter in M10 S2
    By dan152 in forum Troubleshooting
    Replies: 4
    Last Post: 01-05-2006, 12:03 AM
  4. blown tweeter
    By ttomp in forum Troubleshooting
    Replies: 4
    Last Post: 05-12-2005, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts