Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Aug 2012
    Posts
    5

    Default PA D40000.4 Going Into Protection Mode

    I just installed my PA D40000.4 which is driving one pair of DB651's and one pair of DB 6501's. Head unit is a kenwoodKDC-X596 which has 4 volt preamp outputs. Amp is installed under a Suburban front seat with 4"-6" all around.

    Normal listening volume is at about 20-24 volume which seems high to me. At 28 (out of 35) the amp goes into protection mode. It is warm to the touch but not hot.

    Possible culprits would be a partially shorted speaker wire? All speakers are working without undue distortion. Can an in sufficient ground cause heating or the amp? It's grounded right to the body with only a 4" cable. I'm going check to make sure enough paint's been scraped off. Incorrect tuning settings?

    Any help with common causes would be appreciated.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Aug 2012
    Posts
    5

    Default Update

    I've checked the voltage at the amp and it's 12.84. I'll have to wait until the morning to check the ground. What's odd is that when plugging and unplugging the rca cables, the sound level increases dramatically when the RCA plugs are inserted halfway, then decreases to a very low level when they're inserted all the way.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Aug 2012
    Posts
    5

    Default Solved!

    It was a partially grounded speaker wire. Didn't show up with my digital multi meter but did overheat the amp at higher volume levels.

    Many thanks to the PA tech that stayed on the phone with me for a half hour while I tested.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Replies: 1
    Last Post: 03-29-2012, 03:36 PM
  2. Need Help NEED HELP!! Hpsa500 in protection mode!
    By polkanddie in forum Electronics
    Replies: 2
    Last Post: 12-30-2011, 09:46 PM
  3. Need Help Subwoofer in Protection Mode?
    By cjpink in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 11-20-2011, 09:39 PM
  4. Amp goes into protection mode
    By Bubba -NJ in forum Car Audio & Electronics
    Replies: 6
    Last Post: 01-23-2008, 03:58 PM
  5. protection mode
    By dant in forum Troubleshooting
    Replies: 2
    Last Post: 10-11-2003, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts