Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Posts
    74

    Default No sound from tweeter please help.

    I turned on my equipment today and realized that the tweeter in one of my RTi A7's isnt working. What should i do to test what is wrong? I tried hooking it up to 4 different amps and still no go. Everything else seems to work just fine though.
    HT: M5510-Prox2/PN51E550/NR708/M282(3)/RTi A7/CSi A6/FXi A6/DSWPro660x2/PS3/HTPC
    Office: Belkin PF60/PN43E450/Marantz 1501/PSB 400/Image C4/WD Live TV
    2-Channel: Yamaha C4/M4(2)/DQ-10's/DQ-1w(2)/SBT/Pioneer R2Rl/Technics SL-7/AR EB101
    Desk: QSC RMX850/Behringer B2030P

  2. #2

    Member Sales Rating: (0)

    Join Date
    Feb 2012
    Location
    Anaheim, CA
    Posts
    543

    Default

    Are you bi-wired or bi-amped?
    Polkaudio Fronts: RTi A7's Vr3 Fortress Edition / Wyred 4 Sound mAMP's
    Polkaudio Center: CSi A6 Vr3 Fortress Edition
    Polkaudio Surrounds: FXi A6's
    Sub: SVS PC12-NSD
    Marantz SR-7008
    Marantz TT-15S1
    BDP-Denon DBT-1713UD
    Denon AH-D5000's
    Synology DS 212j-4TB
    TV: Panasonic TC P55VT30

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    N.E.PA
    Posts
    141

    Default

    Do you own A multimeter? If you do remove the tweeter and check to see if the voice coil is open.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Posts
    74

    Default

    i have a multimeter, theres no resistance when i touch the two leads after i disconnect the tweeter. I also swapped it into my other A7 and no sound from the tweeter.
    HT: M5510-Prox2/PN51E550/NR708/M282(3)/RTi A7/CSi A6/FXi A6/DSWPro660x2/PS3/HTPC
    Office: Belkin PF60/PN43E450/Marantz 1501/PSB 400/Image C4/WD Live TV
    2-Channel: Yamaha C4/M4(2)/DQ-10's/DQ-1w(2)/SBT/Pioneer R2Rl/Technics SL-7/AR EB101
    Desk: QSC RMX850/Behringer B2030P

  5. #5

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    N.E.PA
    Posts
    141

    Default

    It sounds like its time to buy a replacement tweeter. You can contact polk to find out how much they cost and tell them you are a member here on this forum I believe it gets you some degree of discount when ordering replacement parts. Or you can try that auction site and see if any used ones are available.

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Posts
    74

    Default

    X.x called earlier, hopefully the other one doesn't go either.
    HT: M5510-Prox2/PN51E550/NR708/M282(3)/RTi A7/CSi A6/FXi A6/DSWPro660x2/PS3/HTPC
    Office: Belkin PF60/PN43E450/Marantz 1501/PSB 400/Image C4/WD Live TV
    2-Channel: Yamaha C4/M4(2)/DQ-10's/DQ-1w(2)/SBT/Pioneer R2Rl/Technics SL-7/AR EB101
    Desk: QSC RMX850/Behringer B2030P

  7. #7

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    31,215

    Default

    You more than likely sent a clipped signal from the amp that drives your fronts. Clipping will occur when the volume level spikes or is flat out too high and the amp doesn't have the power reserve to handle it. Looking at the specs for your amp I see it weighs 18 lbs., which means it doesn't have much of a power supply. Hell, I've got CD players that weigh more than that. The solution is to either keep the volume level lower or buy a beefer amp(s).
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  8. #8

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Posts
    74

    Default

    Yeah, i know my amps arent great in the HT, I do want to upgrade to better amps soon.
    HT: M5510-Prox2/PN51E550/NR708/M282(3)/RTi A7/CSi A6/FXi A6/DSWPro660x2/PS3/HTPC
    Office: Belkin PF60/PN43E450/Marantz 1501/PSB 400/Image C4/WD Live TV
    2-Channel: Yamaha C4/M4(2)/DQ-10's/DQ-1w(2)/SBT/Pioneer R2Rl/Technics SL-7/AR EB101
    Desk: QSC RMX850/Behringer B2030P

  9. #9

    Member Sales Rating: (0)

    Join Date
    Oct 2009
    Location
    Florida
    Posts
    157

    Default

    I think your tweeter is DOA. :(

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help no sound from a9 tweeter
    By superjunior in forum Troubleshooting
    Replies: 22
    Last Post: 11-04-2009, 07:59 PM
  2. fuzzy tweeter sound
    By CAvolleyballguy in forum Speakers
    Replies: 1
    Last Post: 03-15-2008, 09:21 PM
  3. Replies: 5
    Last Post: 08-30-2007, 04:27 PM
  4. Tweeter - Liquid Sound
    By VR3 in forum Speakers
    Replies: 2
    Last Post: 04-17-2005, 10:14 PM
  5. RT5 - No sound from tweeter? Help
    By wmcguirk in forum Troubleshooting
    Replies: 3
    Last Post: 02-21-2004, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts