Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    Member Sales Rating: (1)

    Join Date
    Nov 2010
    Location
    Southern California
    Posts
    586

    Default Help me if u can! Parasound Hca Amp

    Need help. Picked up a used Parasound at an estate sale. When I power it up, the "Current overload" light goes on with one channel. I keep powering and unpowering, same result. Any suggestions? The other channel works fine.
    LIVING ROOM: Pioneer PDP-6070HD, Pioneer Elite SC-25, Pioneer Elite BDP-05FD,
    Emotiva XPA-5, Emotiva USP-1, Polk LSI15's, Polk LSiC, Velodyne 12", Mirage Nanosat Prestige rears, MIT AVT Speaker Cables, Audioquest King Cobra Interconnects, Panamax M5300pm Surge Protection/ Power Conditioning
    BEDROOM: VIZIO 32" LCD, Pioneer Elite VSX-23txh, Pioneer Elite BDP-23FD, Parasound HCA-2205A, Mirage Nanosat Prestige Speakers 5.1, Mirage S8 Sub, Monoprice cables, APC Surge Protection.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Feb 2012
    Location
    Anaheim, CA
    Posts
    440

    Default

    Don't know if you got the manual with it but here it is... http://www.parasound.com/pdfs/vintage/hca1500aom.pdf

    Current Overload LEDs
    The Current Overload LEDs for left and right channels will only illuminate if the unit is driven past its
    maximum current capacity. These LEDs are not clipping indicators, but rather are designed to signal you
    when you are exceeding the limits of your amplifier. If these LEDs light, it’s usually a sign that your
    speaker impedance is too low, resulting in too much current draw from the amplifier's power supply. In
    virtually all imaginable listening situations with recommended loads, these LEDs should never illuminate.
    Polkaudio Fronts: RTi A7's Vr3 Fortress Edition
    Polkaudio Center: CSi A6 Vr3 Fortress Edition
    Polkaudio Surrounds: FXi A6's
    Sub: SVS PC12-NSD
    Marantz SR-7008
    Marantz TT-15S1
    BDP-Denon DBT-1713UD
    Denon AH-D5000's
    Synology DS 212j-4TB
    TV: Panasonic TC P55VT30

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2011
    Location
    fla
    Posts
    1,694

    Default

    Parasounds have occausional issues with output relays when they are of age. No biggie can purchaced from parasound, (not expencive) but i would get it checked out . It is a very good amp and well worth having it serviced.
    Main Rig:
    Krell KAV 250a
    McIntosh MC 2120 bi-amped
    Into JBL L123 drivers
    Rane external crossover.
    MIT exp 1 ic's
    Perreaux SA33 class A preamp
    AQ kingcobra ic's
    ADCOM GDA 700 DAC ( MODDED)
    YAMMY CDC-665
    Marantz 6100 tt w/pickering XV-15/625E cart.
    Monster HTS 3600 power conditioner
    POLK RTA-12C'S W/ RDO194 TWEETS, clarity ESA caps mills risistors (full mod)
    MIT exps2 speaker cable

  4. #4

    Member Sales Rating: (1)

    Join Date
    Nov 2010
    Location
    Southern California
    Posts
    586

    Default

    Forgot to mention that the "current overload" red light is on even when the amp is not connected to anything, speakers OR rca inputs. I only have the amp plugged into the wall outlet. I had read somewhere it may be a loose screw between the capacitors. Maybe can confirm this. I did call Parasound, but they just fowarded me to a local repair shop
    LIVING ROOM: Pioneer PDP-6070HD, Pioneer Elite SC-25, Pioneer Elite BDP-05FD,
    Emotiva XPA-5, Emotiva USP-1, Polk LSI15's, Polk LSiC, Velodyne 12", Mirage Nanosat Prestige rears, MIT AVT Speaker Cables, Audioquest King Cobra Interconnects, Panamax M5300pm Surge Protection/ Power Conditioning
    BEDROOM: VIZIO 32" LCD, Pioneer Elite VSX-23txh, Pioneer Elite BDP-23FD, Parasound HCA-2205A, Mirage Nanosat Prestige Speakers 5.1, Mirage S8 Sub, Monoprice cables, APC Surge Protection.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Aug 2012
    Location
    Pennsylvania
    Posts
    118

    Default

    If the repair shop is listed on the Parasound site list as an official repair shop, then that's probably the place to take it to, if it needs repairs.

    http://www.parasound.com/misc/us_svc.php

    Have you tried connecting preamp, and turning preamp and source on before you turn on amp? When I got my HCA-1500A a month ago, I plugged it in without preamp connected. The little yellow light came on as soon as I plugged it in, but when I turned it on, it wouldn't go to standby or normal. Contacted the guy who sold it to me, who recommended that I connect preamp and turn on preamp and cd player, then amp. It's worked like a charm since. Just a suggestion.

    I think the proper order is: connect preamp, connect speakers, plug in amp/preamp/source, turn on source, then preamp, then amp. Give it a shot. Initially, there was a bit of a delay getting to Normal/green; that's mostly gone. Also, if anyone has comments/corrections, please feel free to jump in, especially if I got anything wrong.

    It's a great-sounding amp. Definitely an improvement over my Adcom GFA-545. My LSi9s love it. Hope this helps (or at least doesn't hurt).

  6. #6

    Member Sales Rating: (1)

    Join Date
    Nov 2010
    Location
    Southern California
    Posts
    586

    Default

    Decided to pop the top on the amp. Looked for any thing out of place or loose. Leaky componenets etc. To my surprise found a loose
    wiring harness. Works perfect. Thanks to all who chimed in.
    LIVING ROOM: Pioneer PDP-6070HD, Pioneer Elite SC-25, Pioneer Elite BDP-05FD,
    Emotiva XPA-5, Emotiva USP-1, Polk LSI15's, Polk LSiC, Velodyne 12", Mirage Nanosat Prestige rears, MIT AVT Speaker Cables, Audioquest King Cobra Interconnects, Panamax M5300pm Surge Protection/ Power Conditioning
    BEDROOM: VIZIO 32" LCD, Pioneer Elite VSX-23txh, Pioneer Elite BDP-23FD, Parasound HCA-2205A, Mirage Nanosat Prestige Speakers 5.1, Mirage S8 Sub, Monoprice cables, APC Surge Protection.

  7. #7
    Audiophile
    Member Sales Rating: (30)

    Join Date
    Mar 2006
    Location
    Seattle
    Posts
    11,105

    Default

    Congrats on the easy fix! Always the best find!

  8. #8

    Member Sales Rating: (0)

    Join Date
    Aug 2012
    Location
    Pennsylvania
    Posts
    118

    Default

    Never open the case! Except sometimes. Congrats, enjoy!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Two Parasound HCA-750a's or One Parasound HCA-1200mkii?
    By audiocr381ve in forum 2 Channel Audio
    Replies: 28
    Last Post: 05-06-2012, 06:53 PM
  2. Parasound HALO pre with non-Parasound amp?
    By Serendipity in forum 2 Channel Audio
    Replies: 4
    Last Post: 02-08-2012, 03:08 PM
  3. Need Help Parasound Halo P3 preamp verses Parasound Halo JC-2 preamp
    By Beta in forum 2 Channel Audio
    Replies: 1
    Last Post: 04-24-2010, 04:30 AM
  4. Parasound
    By Willow in forum Electronics
    Replies: 10
    Last Post: 01-15-2008, 10:46 AM
  5. Replies: 22
    Last Post: 09-08-2006, 09:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts