Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Nov 2012
    Posts
    2

    Default db840DVC 8" sub making crackling and popping noises

    I'm using a Dual XPE2700 400W Max, 2-Channel amp and haven't even had this setup for a year yet. Every now and again I notice that the subwoofer is making these weird noises that sound like popping, hissing, and crackling. I'm hoping that that it's not blown. Any idea what could be causing this?

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Brownsburg, Indiana
    Posts
    9,679

    Default

    Quote Originally Posted by Futs View Post
    I'm using a Dual XPE2700 400W Max, 2-Channel amp and haven't even had this setup for a year yet. Every now and again I notice that the subwoofer is making these weird noises that sound like popping, hissing, and crackling. I'm hoping that that it's not blown. Any idea what could be causing this?
    Check your wiring and if possible re-cut and connect the speaker wires and your ground/power wire on the amp. As I am sure you know it could either be the amp or the sub. Without running the sub off another amp there isnt a good way to isolate the problem.

    How do you have the amp wired? It is bridged, are you running 2 subs, one off each channel, ect.
    Advice is free, the Flea Market is earned - F1Nut

    Lessons cost money, good ones cost LOTS - Tony Beets

    HT: APC H15 | Pio 51FD | Uverse | Xbox 360 | Squeezebox Classic | Integra DTR 5.9 | Carver AV-705x & M1.0t MKII Opt002 | LSi 15 | LSiC | LSi F/x | Kimber Hero IC & 8VS SC

    Office: Win 7 -> DacMagic w/ Pangea PSU | Sunfire TGP-II | Parasound HCA-750ii | Polk RTA 11TL | Cables TBA

    Bedroom: Uverse | Roku 2 | Samsung LCD | SurroundBar 2000

    Sales Rating
    Gear

  3. #3

    Member Sales Rating: (0)

    Join Date
    Nov 2012
    Posts
    2

    Default

    I'll try reconnecting the speaker wire and getting new mounts. I've regrounded the wire already. I have the amp wired bridged. 1 sub off 1 amp.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. No more popping noises but.....
    By audiofiend in forum Car Audio & Electronics
    Replies: 0
    Last Post: 02-26-2009, 01:22 AM
  2. popping noises coming from everywhere
    By audiofiend in forum Car Audio & Electronics
    Replies: 6
    Last Post: 02-23-2009, 01:00 PM
  3. My Speakers making noises help
    By GetB1azed in forum Troubleshooting
    Replies: 2
    Last Post: 06-04-2004, 05:20 PM
  4. Speakers making noises help
    By GetB1azed in forum Car Audio & Electronics
    Replies: 12
    Last Post: 05-25-2004, 12:48 AM
  5. Car speakers making noises help
    By GetB1azed in forum Speakers
    Replies: 1
    Last Post: 05-24-2004, 06:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts