Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Posts
    3

    Default PSW111 Low Thumping, Clicking Sound

    I have a PSW111 Powered Subwoofer that I'm using in my Home theater system. It has worked fine for a couple of years. Just the other day a low thumping, clicking sound started. I unplugged the subwoofer from my Onkyo TXSR608 Home theater receiver and simply plugged the power cord in the outlet to see if I continued to get the low thumping, clicking sound. I did. Anybody have this problem, or any suggestions as to how I could go about addressing the problem?
    Thanks...

  2. #2
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,847

    Default

    Hello JJM56,
    Welcome to Polk's forum, the PSW111 is a fine subwoofer, I'm sorry you're having a problem. I would imagine there's something wrong with the unit's bass amplifier. But it should be covered under Polk's three year amp warranty. Give them a call at 1-800-377-7655 for instructions on how to remove the amp and send it in for service. If you prefer email it would be: polkcs@polkaudio.com.
    Cheers, Ken

  3. #3

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Posts
    3

    Default PSW111 Low Thumping, Clicking Sound

    Thanks Ken...I sent them an email asking for instructions. Looks like their offices are closed for the holidays until Wed.
    regards...jim

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Psw111 very low sound
    By Blackswan in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 06-09-2012, 01:17 AM
  2. Need Help PSW111 subwoofer has power but NO sound!! help
    By chateaumau in forum Troubleshooting
    Replies: 1
    Last Post: 04-16-2012, 07:33 PM
  3. PSW10 thumping noises
    By teppy in forum Subwoofer Hookup & Bass Management
    Replies: 1
    Last Post: 09-23-2008, 05:47 AM
  4. LSI25 thumping
    By crazy4plaid in forum Troubleshooting
    Replies: 1
    Last Post: 03-25-2003, 12:28 PM
  5. csi30 thumping w/deep voices
    By Alan M in forum Troubleshooting
    Replies: 3
    Last Post: 01-09-2003, 12:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts