Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 13 of 13

Thread: PSW110 problems

  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    4

    Unhappy PSW110 problems

    I just got a new psw110 for christmas and that day with my old sony receiver it was working like a charm, I did my best to break it in. Then the next day i got a new receiver as another gift and its a Yamaha RX-V465. For the past couple of days it working perfectly fine. My subwoofer cable finally came in, was using a regular RCA cable, now all of a sudden the 110 makes these weird loud noises. I try changing the volume to see if that would fix it but whenever i touch the volume nob the noises get worse. I tried the original RCA cable i was using and its now doing the same exact problem that it is doing with the subwoofer cable. Now my question what is wrong with, can i fix it easily or should i just bring the sub back?

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Location
    North of New Orleans
    Posts
    3,313

    Default

    Welcome to Club Polk.
    I would recommend calling Polk Audio customer service at 1-800-377-7655 9 AM - 5:30 PM Monday - Friday Eastern Time for assistance. Polk Audio offers excellent service.

    One question though, does the subwoofer display this behavior if you connect it back to the old Sony receiver?

    Main HT/2 ch:
    Pioneer SC-07, BDP-05FD, Emotiva XPA-5 x 2, XPA-1 x 2,
    Polk Audio LSi25, RTi12 x 2, LSi15 x 4, LSiC x 2, PSW1000 x 4,

    MB HT/ 2 ch:
    LG 47LM5800, Pioneer SC-1523, BDP-23FD, Sony BDP-S790, Emotiva XPA-2, XPA-5,
    Polk Audio LSi25,15, CSi5, LSiFX, PSW505 x 4

    Listening Room 2 ch:
    McIntosh MC162, MC202, C15, C41, C42, MA6500, MA6900, MCD201
    Emotiva RSP-2, RPA-1, ERC-2
    Adcom GCD 750, GFP 750, GFA 5802
    Polk Audio LSi7,9, 15

  3. #3

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    4

    Default

    Quote Originally Posted by xcapri79 View Post
    I would recommend calling Polk Audio customer service at 1-800-377-7655 9 AM - 5:30 PM Monday - Friday Eastern Time for assistance.

    One question though, does the subwoofer display this behavior if you connect it back to the old Sony receiver?
    the problem with that is, that i gave my old sony receiver to my uncle so i can't test it out again with that receiver, im going to try it out on my father's receiver when i get a chance

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    1

    Default

    I just started having the same problem. When I touch the sound knob the sub "bumps". The sub has been working flawlessly for the past few days until recently when it got really loud even though I had put the receiver on mute. I even unplugged the rca cable hookup from the back of the sub, and same problem persisted. Any input appreciated.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Oct 2009
    Posts
    11

    Default

    maybe you got a defective or grounded knob, try to bring it back, i've been using my polk psw110 for 3mos never encountered any problems.

  6. #6

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    4

    Default

    Quote Originally Posted by braaaaay View Post
    maybe you got a defective or grounded knob, try to bring it back, i've been using my polk psw110 for 3mos never encountered any problems.
    yea the loud popping noises only happen whenever i touch the volume nob and they just keep on happening after

  7. #7

    Member Sales Rating: (0)

    Join Date
    Dec 2009
    Posts
    4

    Default

    Quote Originally Posted by PikSkrit View Post
    I just started having the same problem. When I touch the sound knob the sub "bumps". The sub has been working flawlessly for the past few days until recently when it got really loud even though I had put the receiver on mute. I even unplugged the rca cable hookup from the back of the sub, and same problem persisted. Any input appreciated.
    so i called polk this morning and they said to either return the sub back to the store that you had purchased it or if you cant return it, they will send an amplifier to you. The customer rep said that is probably what the problem is, the amp went bad on the sub

  8. #8

    Member Sales Rating: (0)

    Join Date
    Feb 2011
    Posts
    1

    Default Same Problem Here

    I have been using this sub for a while, and now all the sudden the sub will just start at full volume. I turn it all the way down and it stays at full blast. Then I'll wiggle it a little bit and it will go to the proper volume. I found that if I apply upward pressure to the volume knob, it works fine, however if I push down on the knob, it goes at full volume.

    Sounds like either a cheap volume pot or a bad solder job to me. I've set my volume to what I like, and I've had to resort to taping the volume knob so that vibrations from the sub don't knock the volume knob loose and make it blast full volume right in the middle of a movie.

  9. #9

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Posts
    1

    Default Sub feedback when touching the volume control

    I have been having the same issue with feedback in the sub when I touch the volume control. I called Customer support and the Rep said he would send a new SW amp out for me to replace. Can't ask for more then that!

  10. #10

    Member Sales Rating: (0)

    Join Date
    Dec 2010
    Posts
    20

    Default

    I think I just started having the same problem today with my new/refurb PSW110 sub that I just got in about 3 or 4 weeks ago. My mom was watching TV and all the sudden it started making noises like if fireworks were going off outside in the distance on 4th of July. Even if you paused the DVR while watching TV it kept making the noises. I flipped the power switch on the back of the sub and turned my receiver on and off and then the noise went away. I will see if it makes the noises again or if it was a one time thing (I think it happened once before but not totally sure). If it happens again, or anything else goes weird with it, I will definitely call Polk Audio to replace it. Everything else in my system is new, so I don't think it could be it.

  11. #11

    Member Sales Rating: (0)

    Join Date
    Aug 2008
    Location
    Gatineau, Quebec Canada
    Posts
    4,262

    Default

    Quote Originally Posted by jnnt29 View Post
    I have been having the same issue with feedback in the sub when I touch the volume control. I called Customer support and the Rep said he would send a new SW amp out for me to replace. Can't ask for more then that!
    Quote Originally Posted by HDDoobie View Post
    I think I just started having the same problem today with my new/refurb PSW110 sub that I just got in about 3 or 4 weeks ago. My mom was watching TV and all the sudden it started making noises like if fireworks were going off outside in the distance on 4th of July. Even if you paused the DVR while watching TV it kept making the noises. I flipped the power switch on the back of the sub and turned my receiver on and off and then the noise went away. I will see if it makes the noises again or if it was a one time thing (I think it happened once before but not totally sure). If it happens again, or anything else goes weird with it, I will definitely call Polk Audio to replace it. Everything else in my system is new, so I don't think it could be it.
    Try calling this during working hours;
    Free Expert Technical Support
    Have a question you needed answered but didn't know who to turn to? Our in-house knowledgeable staff has over 75 years of combined experience and will walk you through setup and operation. We don't outsource to foreign countries.


    Technical Support is available Mon-Fri 9 AM-5:30 PM EST via Live Chat and 1-800-377-7655. You can also send Technical Support a message via email anytime at polkcs@polkaudio.com.
    ..
    I believe the live chat icon appears at the top to the right end side of Polk's site during working hours. If you look at the history of this thread, this is how the OProb. got resolved with the assistnace of Polk Technical support. As usual, I am confident Polk will help you to resolve your problem promptly if you take the time to adress your issue with one of the means above.

    BTW; Welcome to Club Polk!
    DARE TO SOAR:
    “Your attitude, almost always determine your altitude in life” ;)

  12. #12

    Member Sales Rating: (0)

    Join Date
    Jan 2013
    Posts
    1

    Default

    So I too am experiencing the same problem I called tech support and they told me that unless I can find my receipt from best buy that they would do no such thing in sending me an amplifier. I've been a polk customer my whole life and never had an issue you but to be turned away on this when i see so many others have been help kinda makes me think twice about continuing to buy their stuff.


    Has anyone attempted a manual repair? Can it be traced to one component of the amplifier?

  13. #13
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,711

    Default

    Hello,
    Welcome to Polk's forum, sorry you're having a problem. In order for a repair to happen under warranty you need to be able to provide a proof of purchase. Do you have a copy of a cancelled check or credit card statement that supports your claim? Did you register your product with Polk when you bought it?
    Regards, Ken

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. PSW110 for $125 at Crutchfield.com
    By Glen_T in forum Speakers
    Replies: 1
    Last Post: 12-19-2009, 11:20 AM
  2. PSW10 @$75 vs. PSW110 @ $135
    By stevesul in forum Subwoofer Hookup & Bass Management
    Replies: 6
    Last Post: 12-19-2009, 10:56 AM
  3. PSW110 vs. PSW111...yea, again....
    By KASR in forum Subwoofer Hookup & Bass Management
    Replies: 8
    Last Post: 12-17-2009, 08:57 PM
  4. PSW110 - LFE, or L+R?
    By NaOH in forum Basic Hookup/Wiring Questions
    Replies: 3
    Last Post: 11-24-2009, 07:38 PM
  5. Need Help Psw111 or Psw110
    By hda3ku in forum Speakers
    Replies: 5
    Last Post: 03-23-2009, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts