Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Member Sales Rating: (0)

    Join Date
    Sep 2007
    Posts
    53

    Default Wireless Subwoofer Question

    I have a Polk PSWI 225 which normally works great but lately is not coming on as often as before. When watching movies with strong bass, it comes on and stays on. But when watching TV, it is often not coming on at all or going off pretty quickly. It never did this before. Makes me wonder if it needs cleaning or something similar. I did try turning both the wireless transmitter and subwoofer on and off to reconnect but no change.
    Any ideas?
    Thanks for any help.

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jan 2011
    Location
    Houston, TX
    Posts
    100

    Default

    It is probably best to contact polk directly for some advice. From my experience their tech support is pretty good.

    Do you notice this at all listening levels or just at lower ones?
    Living Room:
    Paradigm Cinema 330 x 3, Pioneer 9040TXH

    Media Room:
    RTi12, CSi5, F/Xi3, RTi4, Onkyo SR805, SVS PB12 Plus/2, HSU MBM

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jul 2010
    Posts
    994

    Default

    Sometimes they only come on when the volume is set above a certain threshold level - is the volume way down?

    Have the crossover/low pass settings been changed lately? If so, your other speakers might be carrying the load for the sub. This would be my guess, since the sub is kicking in during strong bass parts of movies. I'd check into that and maybe rerun your calibration program.

    Also, is that sub one that is operable as wired as well as in wireless mode? If so, does it work when wired? Might have a problem with the signal transmitter or receiver. Or, for some reason, it might only be working when sending out signals over the LFE channel.
    Last edited by teekay0007; 02-21-2013 at 03:17 PM.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Sep 2007
    Posts
    53

    Default

    Quote Originally Posted by vadang View Post
    It is probably best to contact polk directly for some advice. From my experience their tech support is pretty good.

    Do you notice this at all listening levels or just at lower ones?
    Just on TV programs.

  5. #5

    Member Sales Rating: (0)

    Join Date
    Sep 2007
    Posts
    53

    Default

    I haven't changed any settings and the volume is 1/2 way as before.
    I'll try the direct conection idea. Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Polk Audio Wireless Subwoofer PSWI225 + Wireless Surround F/X
    By jeremys in forum Speakers
    Replies: 0
    Last Post: 10-06-2012, 08:24 PM
  2. Need Help Adding wireless subwoofer to existing 2 subwoofer system
    By rrsjls@msn.com in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 08-08-2012, 01:33 PM
  3. Subwoofer Wireless Kits
    By Shicks18 in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 12-31-2011, 12:05 AM
  4. Connecting Wireless subwoofer to Surroundbar 50?
    By Question718 in forum Basic Hookup/Wiring Questions
    Replies: 0
    Last Post: 10-30-2009, 12:44 PM
  5. POLKs new wireless subwoofer
    By CaligulaPolk in forum Subwoofer Hookup & Bass Management
    Replies: 3
    Last Post: 08-06-2009, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts