Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    Member Sales Rating: (0)

    Join Date
    Aug 2009
    Location
    Northern NJ
    Posts
    381

    Default My Parasound A21 died

    My A21 died yesterday. I think it went into circuit protect mode. The power button stays red and does not turn blue like it is suppose to. I unplugged all connectors and cables, unplugged the unit, plugged it in again but got the same result. I checked the fuse and it looked ok. I really never push the amp and it rarely gets beyond slightly warm.

    Good thing it is only a year old and still under warranty.

    Anybody else have this problem?
    Rig1 - Totem Hawks, Benchmark HDR, Parasound A21, Sonus, Samsung 52 LCD, Audioquest Type4
    Rig2 - LFD LE IV Integrated, Harbeth P3ESR, Rega Dac, MF V-Link, IMAC, Audioquest Type4

  2. #2

    Member Sales Rating: (0)

    Join Date
    Oct 2010
    Location
    Sydney, Cape Breton Island,NS Canada
    Posts
    473

    Default

    Glad to hear it is still under Warranty.
    Home Theatre.............

    Pioneer SC-35
    Polk RTi10's Fronts
    Polk CSiA6 Center
    RTi4 Surrounds
    SVS PB-12 Sub


    2 Channel.............................

    Yaqin MC-100B
    Energy RC-70 Speakers
    Arcam CD-192 Disc Player
    Van Den Hul Interconnects

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2011
    Location
    fla
    Posts
    1,810

    Default

    Put a mrter on yhe fuse, sometimes they can look good but be blown at the solder connection in the cap out of vision. If no meter replace it before you ship just to be sure! Had this happen to me.
    Main Rig:
    Krell KAV 250a
    McIntosh MC 2120 bi-amped
    Into JBL L123 drivers
    Rane external crossover.
    MIT exp 1 ic's
    Perreaux SA33 class A preamp
    AQ kingcobra ic's
    ADCOM GDA 700 DAC ( MODDED)
    YAMMY CDC-665
    Marantz 6100 tt w/pickering XV-15/625E cart.
    Monster HTS 3600 power conditioner
    POLK RTA-12C'S W/ RDO194 TWEETS, clarity ESA caps mills risistors (full mod)
    MIT exps2 speaker cable

  4. #4

    Member Sales Rating: (7)

    Join Date
    Nov 2002
    Location
    Northern Virginia
    Posts
    1,224

    Default

    I had a blown fuse in my JC2 preamp. Didn't feel like messing around trying to fix it myself, when a blown fuse could be an indicator of some other problem, and it's under warranty for a long time. Shipping to Parasound in California has to be in the original box, and can be expensive if insured at full value. But, they fixed it within a couple of days and sent it back in a new box at their expense.

    I'd start by either calling or emailing Parasound. They handle problems very well.
    1. JM Labs Electra 920.1 and CC30; MB Quart Vera Sub; Pioneer SC-57; Squeezebox Touch; Panasonic BDT-500 Blu-Ray; Samsung 52" LCD; FIOS; PS Audio Power Plant Premier; MIT S3 cables
    2. Polk SDA-SRS 2.3TL; Sonic Frontiers Line 3 SE; Classe Model 25; Marantz SA8004; Acoustech PH1P; Squeezebox Touch; Music Hall MMF7; PS Audio P1000; MIT S2 cables
    3. Polk SDA 2A; Parasound Halo JC-2 and A21; Musical Fidelity X-DAC; Squeezebox Touch; PS Audio 4.7; MIT S1 cables

  5. #5

    Member Sales Rating: (0)

    Join Date
    Aug 2009
    Location
    Northern NJ
    Posts
    381

    Default

    Thanks for the advice. I will replace the fuse just to make sure before I ship it out. I do have the orignal box so am all set if the replacement fuse does not fix the problem.
    Rig1 - Totem Hawks, Benchmark HDR, Parasound A21, Sonus, Samsung 52 LCD, Audioquest Type4
    Rig2 - LFD LE IV Integrated, Harbeth P3ESR, Rega Dac, MF V-Link, IMAC, Audioquest Type4

  6. #6

    Member Sales Rating: (0)

    Join Date
    Aug 2009
    Location
    Northern NJ
    Posts
    381

    Default

    I called Parasound and spoke to Tony. Said I should send it in. It is all packed up a ready to go out this wekend. Not happy about the $100+ dollars to send it across country but it could be worse.
    Rig1 - Totem Hawks, Benchmark HDR, Parasound A21, Sonus, Samsung 52 LCD, Audioquest Type4
    Rig2 - LFD LE IV Integrated, Harbeth P3ESR, Rega Dac, MF V-Link, IMAC, Audioquest Type4

  7. #7

    Member Sales Rating: (20)

    Join Date
    Jan 2004
    Location
    7th Circle of Hell - aka DFW
    Posts
    10,665

    Default

    This is one of the reasons I like to buy from a local dealer, if something goes bad I can take it up there and they'll deal with it. If you bought from a dealer locally that's the route I'd go.
    Main HT
    Magnepan 1.6QR fronts, POlk R15 surrounds, Pioneer SC-25, Parasound Halo A23, Oppo BDP-105, Panasonic TC-P60ZT60, Sony PS3, Apple TV

    Bedroom System
    Polk Blackstone TL3, Polk PSWi225 Wireless Sub, HK 3490 Integrated, Oppo BDP-103, Sharp Aquos 32" TV, Apple TV

    Office Rig
    27" iMac w/Amarra, AudioQuest Dragonfly 1.2, Focal XS Book, Schiit Valhalla, Cypher Labs Theorem 720, Philips Fidelio X1, Sennheiser HD600, HiFiMan HE-500, B&W P7, LG 47LM7600, Sony PS3, Apple TV

  8. #8

    Member Sales Rating: (0)

    Join Date
    Aug 2009
    Location
    Northern NJ
    Posts
    381

    Default

    I bought from Audio Advisor because local dealers did not have one in stock. In hind-sight, I should have purchased thru a local for just such reasons. Live and learn.
    Rig1 - Totem Hawks, Benchmark HDR, Parasound A21, Sonus, Samsung 52 LCD, Audioquest Type4
    Rig2 - LFD LE IV Integrated, Harbeth P3ESR, Rega Dac, MF V-Link, IMAC, Audioquest Type4

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Two Parasound HCA-750a's or One Parasound HCA-1200mkii?
    By audiocr381ve in forum 2 Channel Audio
    Replies: 28
    Last Post: 05-06-2012, 06:53 PM
  2. HK died...
    By Ron Temple in forum Electronics
    Replies: 20
    Last Post: 06-20-2007, 08:37 AM
  3. Very very sad.. 360 died..
    By WolfKiyoshi in forum Video Games
    Replies: 3
    Last Post: 05-05-2007, 10:10 PM
  4. Replies: 22
    Last Post: 09-08-2006, 09:18 AM
  5. amr 50 died
    By craig3t in forum Troubleshooting
    Replies: 1
    Last Post: 08-06-2006, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts