Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2013
    Posts
    1

    Default PA880 Help Needed - Protection Light

    Let me start off, I received this amp as a gift from a family member and was purchased through Best Buy. I installed the amp this afternoon and everything seemed fine. I also installed 2 brand new Dxi104 dvc's at the same time, As said in the manual I played music at little less than medium to run them in for about a half hour. I had the gain turned to about 1/4 of the knob. I checked the amp several times to make certain that it was not getting hot. After the half hour, It worked flawless and sounded killer. I turned off the truck and went in. I came back out about 1-2 hours later and the amp was in protection mode. I checked all the connections and fuses, I even ran a new remote power wire and still the same. I am missing something? Is there anything I should check? I disconnected the power wire and I am going to leave it off until I can figure out something. Thanks.

  2. #2

    Member Sales Rating: (1)

    Join Date
    Mar 2004
    Location
    College Station, TX
    Posts
    7,176

    Default

    How did you wire the subs? Also, sometimes if you're not careful, tiny strings of wire can cross over to the other terminal, causing a small short. So check your connections!
    -Cody
    Music is like candy, you have to get rid of the rappers to enjoy it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Help Needed - Microwave Oven Light Bulb Question
    By toucanet in forum The Clubhouse
    Replies: 2
    Last Post: 03-18-2012, 03:19 PM
  2. Need Help pa880 amp
    By qellis in forum Basic Hookup/Wiring Questions
    Replies: 1
    Last Post: 11-20-2011, 04:12 PM
  3. pa880 install with OEM HU
    By wekieboom in forum Basic Hookup/Wiring Questions
    Replies: 0
    Last Post: 09-13-2011, 09:22 PM
  4. POlK PA880.1 cut off
    By mizike in forum Troubleshooting
    Replies: 21
    Last Post: 11-21-2010, 12:03 PM
  5. Adcom thermal protection light stays on
    By autoconsortium in forum Electronics
    Replies: 2
    Last Post: 09-11-2005, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts