Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Location
    Milwaukee
    Posts
    9

    Default Polk MicroPRO 2000

    Howdy- I purchased a MicroPRO 2000 a couple of years ago and never took it out of the box except for once to look at it. We were in the process of moving at the time and I couldn't pass up the deal. I finally opened it up again last night and plugged it in. It has this rattle/buzz/static that is fairly constant. It sounds just like if there was something resting on the top of the driver if it was pointed vertically. I have refoamed a few speakers and it almost sounds like a voice coil rubbing. With such a thick surround, is that possible? Putting my hand on the dustcap muffles it a bit, but does not make it stop. At high volumes it does not seem to be worse. Any ideas? I would hate to scrap such a new and nice unit. Thanks- Jim

  2. #2

    Member Sales Rating: (0)

    Join Date
    Oct 2003
    Posts
    868

    Default

    contact Polk customer service. They might point you in the right direction.

  3. #3

    Member Sales Rating: (41)

    Join Date
    Apr 2008
    Location
    Milwaukee, WI
    Posts
    8,741

    Default

    Set the crossover and 80hz. I'm betting you have it up higher. When I owned mine a rattle noise would occur by the dust cap but when set to 80hz or below it went away.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Location
    Milwaukee
    Posts
    9

    Default

    I tried the crossover and it is the same high or low. After fooling around with it a little more I'm not sure that it isn't an amp problem. It plays great occasionally, then has bouts of static/fuzz/rattle and then stops playing altogether. It won't restart playing unless I adjust the volume on the stereo. I left it in the 'always on' mode and it does this. I've had it on right now for the last 30 or so minutes and it plays for maybe half the time, very static-y while playing. With a decently loud volume, it will come and go on its own. At low volumes I have to turn the stereo up to get it to come back on. It isn't the signal cord either. Strange.
    Last edited by jsours; 04-15-2013 at 07:52 AM. Reason: grammar

  5. #5
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,710

    Default

    Hello,
    I'm sorry you're having a problem. Give Polk's CS department a call at 1-800-377-7655 or send them an email at: polkcs@polkaudio.com and they'll help out.
    Regards, Ken

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Location
    Milwaukee
    Posts
    9

    Default

    Thank you all.

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jul 2010
    Posts
    996

    Default

    I had a similar issue with my MicroPRO 2000 once.

    I had it sitting on carpet and something just didn't sound right about it. However, my problem was volume related and occurred more when playing certain types of music or movie soundtracks. It turned out to be that the power cord was curled under the sub and at higher volumes/deep bass passages the passive on the bottom of the sub was hitting the top of the power cord making a terrible noise.

    Since then, I have realized the difference power cords can make to producing good sound!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help Polk Audio DSW microPRO 1000 vs 2000
    By dvd_rw in forum Speakers
    Replies: 12
    Last Post: 10-06-2011, 10:33 PM
  2. Which Sub? Pro 500 or Micropro 2000
    By mr300 in forum Speakers
    Replies: 0
    Last Post: 09-29-2010, 09:49 PM
  3. Need Help Please help me set up my Micropro 2000
    By dhart86 in forum Subwoofer Hookup & Bass Management
    Replies: 7
    Last Post: 07-17-2010, 10:52 AM
  4. For Sale Micropro 2000
    By leroyjr1 in forum For Sale (FS) Classifieds
    Replies: 5
    Last Post: 01-21-2010, 09:49 AM
  5. DSW MicroPro 2000
    By jacob.simpson in forum Speakers
    Replies: 2
    Last Post: 02-11-2009, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts