Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2013
    Posts
    2

    Question PSW250 Powered SubWoofer pops randomly

    I bought a complete Polk Audio home theater system several years ago. It included the PSW Powered Subwoofer. After I setup the system, the subwoofer immediately would pop randomly. I finally had to shut it off and haven't used it since. I should have seeked help when it first occurred, but I didn't. Anyway, what is causing these loud pops? What do I need to do to fix it? The subwoofer works, but the loud pops keeps it from being usable.

    Any advice is greatly appreciated. I am a complete noob with sound systems, so be gentle!

    Thanks,
    Bob

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jul 2012
    Location
    central Texas, trailer court on right
    Posts
    731

    Default

    It may simply be that you have the volume knob on the sub turned up too high. Try turning it down to half or even 1/3 of the range. Also check to see where your AVR has the sub set at. If it is -5 db, or a larger number, after lowering the volume on the sub, re-run your auto-cal program. Keep lowering the volume and re-cal until you get close to zero.

    Welcome to Club Polk

  3. #3

    Member Sales Rating: (0)

    Join Date
    Apr 2013
    Posts
    2

    Default

    Thanks RPF65.

    I really don't understand very much about audio devices, but I will study the documentation for the AVR and see if I can find what you speak of.

    I'll report back with my results.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Apr 2010
    Location
    St. Louis, Missouri
    Posts
    51

    Default

    How often did it pop? Was it every few minutes? Did it happen when you went from having loud scenes moving to quiet scenes?

    Could be auto-shutoff causing the popping.
    11.3 Theater
    RTi A7 Fronts - CSi A6 Center - 65-RT DSX Wides - RTi A1 DSX Highs - FXi A6 Rears - FXi A6 Surround Backs
    eD A5-350 (L-LFE) - eD A5-350 (R-LFE) - SVS 20-39+ (Rear-LFE) - Aura Pro x 8 Seats
    Onkyo TX-NR3010 (11.3 Neo:X) - Sony TA-N9000ES Amplifier
    JVC RS-20u - Elite 120" 1.3 Gain - XBMC Processor - TrippLite 30A Full Theater Backup


    2.1 Studio / PC
    Mackie HR824 Powered Monitors - Infinity Kappa Perfect 12" DIY
    Aune USB 24/192 DAC HPA - Sennheiser HD650/600

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Subwoofer starts playing randomly even with receiver off
    By hifigal in forum Subwoofer Hookup & Bass Management
    Replies: 5
    Last Post: 06-05-2012, 10:12 AM
  2. Need Help PSW250 Subwoofer hookup question
    By vstarkwell in forum Subwoofer Hookup & Bass Management
    Replies: 0
    Last Post: 09-26-2011, 06:05 PM
  3. Subwoofer pops
    By lonwa in forum Speakers
    Replies: 7
    Last Post: 10-16-2008, 12:21 PM
  4. Hooking up Powered Subwoofer To Powered Amplifier Port
    By Camden350 in forum Subwoofer Hookup & Bass Management
    Replies: 2
    Last Post: 08-26-2008, 02:00 AM
  5. For Sale PSW250 Subwoofer NEW
    By bbartell in forum Flea Market
    Replies: 15
    Last Post: 10-25-2001, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts