Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7

Thread: Need help

  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    Hemet, Ca
    Posts
    26

    Default Need help

    I want to use my Proton 1200 amp to drive my front polk RTA 11 with the pre outs and have my Onkyo TX-SR 705 to drive my center and rears will this work.

  2. #2

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    New York
    Posts
    256

    Default

    Yes, that will work. I've done it more than once.
    Main system: Denon DP-59L | Audio-Technica AT33EV | Marantz Reference Series SA-11S2 | Classé CP-50, modified | Classé CA-300, modified | Classé DR-10, modified | Classé RC-1 | PSB Stratus Gold i's | DIY Balanced AC Power Conditioner with surge/spike suppression | Acoustic Zen and NeoTech cables | Oyaide and Furutech AC power connectors and receptacles | Hi-Fi Tuning Supreme fuses | Dedicated 20A IG AC line

  3. #3

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    Hemet, Ca
    Posts
    26

    Default

    Wow thanks. I know it sounded stupid but the manual and the Onkyo forum shed no light on it, and I did not want to see smoke.

  4. #4

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    Hemet, Ca
    Posts
    26

    Default

    I am getting my mains this weekend, a one owner set of pristine condition RTA 11's I know they need to be driven harder than the 705 will do in full HT mode with 6 ohm speakers all the way around. Again thanks
    Last edited by satguy08; 04-30-2013 at 09:17 PM.

  5. #5

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    Hemet, Ca
    Posts
    26

    Default

    Ok I got the amp and did a test run on the amp, What happen? Dull, dull,dull. Is using the Onkyo as a pre amp wrong?

  6. #6

    Member Sales Rating: (0)

    Join Date
    May 2012
    Location
    Hemet, Ca
    Posts
    26

    Default

    I got it working, I feel so stupid, read the enclosed instructions stupid.

  7. #7

    Member Sales Rating: (0)

    Join Date
    Aug 2011
    Location
    Ohio
    Posts
    587

    Default

    What did you do wrong?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts