Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4

Thread: Blown Fuse?

  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Location
    Loveland, CO
    Posts
    425

    Default Blown Fuse?

    Last night while watching a movie, there was a click sound and I lost sound in all speakers except for left/right (they are on an amp). I reset the TGR3 tonight but still no front display or sound out of any speakers except for l/r. I pulled the fuse and plan on picking up a match tomorrow.

    Any other suggestions on what it could be?
    7.3 HT: Sunfire TGR-3, Sunfire Series II, Mirage OMD-28, OMD-5 (x4), REL T1 (2), T2, Oppo 103D, Optoma HD8200PRO, 106" screen, SB Touch
    Family Room: Yamaha RX-V2700, RT25i, 42" Samsung, SB Duet
    Pool: Yamaha V2700, SQ Duet, Atrium 60 (2), Atrium 45 (3), Atrium 65sdi

  2. #2
    Audiophile
    Member Sales Rating: (30)

    Join Date
    Mar 2006
    Location
    Seattle
    Posts
    11,187

    Default

    Any power surges or storms?

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2008
    Location
    Loveland, CO
    Posts
    425

    Default

    Nope, no power surges or storms - was during the movie and everything else stayed on fine. I had someone test the fuse today and it seems to be okay. Called Sunfire and they said if I lost display and power, it would need serviced - $570 flat rate plus shipping. OUCH. Cheaper than a new one and can't get much for that price but dang.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Nov 2005
    Location
    Braselton GA
    Posts
    12

    Default

    try disconnecting the speakers then replace the fuse and see if the display comes back

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help PSW 202 Blown fuse - possible short
    By Amelia in forum Electronics
    Replies: 0
    Last Post: 08-15-2010, 04:58 PM
  2. blown fuse?
    By eloplayspolo in forum Car Audio & Electronics
    Replies: 8
    Last Post: 03-24-2008, 10:14 PM
  3. Is it a short, a blown fuse or something else??
    By Sltrudeau in forum Troubleshooting
    Replies: 0
    Last Post: 01-31-2007, 11:11 AM
  4. PSW 150 - blown fuse
    By cdgatti in forum Troubleshooting
    Replies: 3
    Last Post: 11-15-2005, 08:48 PM
  5. blown fuse
    By toan in forum Car Subwoofer Talk
    Replies: 2
    Last Post: 01-20-2003, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts