Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2

Thread: polk momo burnt

  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2013
    Posts
    3

    Default polk momo burnt

    I got a polk momo 15" 4 ohm dvc subwoofer
    -400watts rms
    and my amplifier is cerwin vega 500.1 monoblock
    rms@4 ohms -300watts
    rms@2 ohms -500watts
    i connected the subwoofer in series connection @ 2 ohms and it was working good for soo many days.But my subwoofer had burned last day when i raise the bass in my remote bass controller. :(
    what will be the reason?
    please help me :(
    i connected it in this way Name:  Untitled.gif
Views: 113
Size:  7.6 KB

  2. #2

    Member Sales Rating: (0)

    Join Date
    Oct 2003
    Posts
    868

    Default

    You connected the sub incorrectly... look at the instruction manual for information. You have to connect the speaker temrinal in series.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. polk momo burnt
    By harinarayanks in forum Car Audio & Electronics
    Replies: 3
    Last Post: 07-30-2013, 03:11 AM
  2. polk momo burnt
    By harinarayanks in forum Car Subwoofer Talk
    Replies: 3
    Last Post: 07-27-2013, 08:52 PM
  3. Need Help DSW PRO 600 Burnt part
    By meanuc in forum Troubleshooting
    Replies: 2
    Last Post: 12-14-2012, 09:13 PM
  4. LED done burnt out
    By MillerLiteScott in forum Troubleshooting
    Replies: 18
    Last Post: 05-08-2007, 08:17 PM
  5. MM124 has a burnt smell!
    By LILDRAGON in forum Car Audio & Electronics
    Replies: 4
    Last Post: 01-12-2003, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts