Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 18 of 18
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default MW6511 drivers, Magnet shift, or just FUBAR

    So much for getting good working MW6511. They are in fact MW6511, 2 of them marked CRS+ on the backs. Upon first inspection, they seem to be in good shape. They were wrapped in a ton of bubble wrap. The box was not damaged. The way they were wrapped, it would seem impossible for them to move around at all. I have looked at the magnets...now not sure what i'm "supposed" to be looking for, but i don't see any signs that they moved. But both of them are dead. The voice coils are frozen in place..and i mean FROZEN. They don't move at ALL. I tried the 9 volt trick on them. You get a little click, but thats it. NOTHING moves at all. Now i could see if the magnets shifted, then you'd get scratchy stuff, but you could still move the voice coil. At least some.

    These 2 drivers you can't move anything. To me, these drivers were far over driven, and fried in place. Little or no chance these worked at all, before they were packed up and shipped.



    If anybody has any idea's on these drivers, would love to hear them. I don't see how i can fix them even if it was magnet shift. But i also don't see them completely FROZEN in place due to that either.

  2. #2

    Member Sales Rating: (1)

    Join Date
    Aug 2009
    Location
    central Illinois
    Posts
    3,593

    Default

    Quote Originally Posted by naturallight View Post
    So much for getting good working MW6511. They are in fact MW6511, 2 of them marked CRS+ on the backs. Upon first inspection, they seem to be in good shape. They were wrapped in a ton of bubble wrap. The box was not damaged. The way they were wrapped, it would seem impossible for them to move around at all. I have looked at the magnets...now not sure what i'm "supposed" to be looking for, but i don't see any signs that they moved. But both of them are dead. The voice coils are frozen in place..and i mean FROZEN. They don't move at ALL. I tried the 9 volt trick on them. You get a little click, but thats it. NOTHING moves at all. Now i could see if the magnets shifted, then you'd get scratchy stuff, but you could still move the voice coil. At least some.

    These 2 drivers you can't move anything. To me, these drivers were far over driven, and fried in place. Little or no chance these worked at all, before they were packed up and shipped.



    If anybody has any idea's on these drivers, would love to hear them. I don't see how i can fix them even if it was magnet shift. But i also don't see them completely FROZEN in place due to that either.
    Start a claim that will be the best choice for you in this case.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jan 2012
    Location
    Denver
    Posts
    1,887

    Default

    Looks like all Polkies really need to have a jig to fix these.
    It's is too common thing now.

    Boston A400,VR950, DefTech BP10,, Klipsch Forte,KSP-400,KSF-C5,RF3,RC3.
    JBL L20t,L80t3, EPI 20+,T/E 280, Polk 4,4.5,5A,7C, KEF Coda III, Yamaha NS-690, Genesis 3+.
    SUB:Deftech PF15TL+, DCM TB1010, Velodyne VA08BVX10. Pre: HK AP2500. Amps: BB175, Adcom GFA-535,555II, Rotel RB-990BX.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default

    See this is what i really don't by. These drivers were wrapped in enough bubble wrap to stop any movement of the drivers at all. The box was labeled fragile on it. Not a ding on the box at all.

    Now maybe 1 driver, could be bad, but both, with the same problem....I don't think so.



    This to me smells of a garbage pickup, or something they found in goodwill as a broken set of speakers and just tried to sell the parts out of it. They didn't know what they were really selling as the header did not match with the real speaker. The first ones they sold were in fact MW6510's ..they left the same heading, but the pic shows these were 6511's...which they are. But i get the feeling your dealing with people who know nothing about drivers or speakers....they look nice, must work, type deal. How these could have worked before shipping..i don't see.



    I've looked at these magnets..they don't seem to be out of place as compared to working drivers.

    I don't see how, even if the magnets have shifted some what...one 1 driver maybe, but both??

    The only time i've seen drivers like this, that there completely FROZEN in place is that they are just burnt voice coils that have fused together. Unless somebody has a better idea, i don't see how these drivers ever worked before they were shipped.....

  5. #5

    Member Sales Rating: (0)

    Join Date
    Jan 2012
    Location
    Denver
    Posts
    1,887

    Default

    It may be like that to begin with but all it needs is one drop or a throw in the truck by the handler no matter how many layers of bubble wrap they have.
    Bubble wrap can't prevent shock from dropping or throwing.

    I have couple of them in perfect condition, can't tell anything has shifted but they are frozen so looking at them from outside is no use.
    I haven't tried the jig yet but looks like that's pretty inexpensive to make one.

    Boston A400,VR950, DefTech BP10,, Klipsch Forte,KSP-400,KSF-C5,RF3,RC3.
    JBL L20t,L80t3, EPI 20+,T/E 280, Polk 4,4.5,5A,7C, KEF Coda III, Yamaha NS-690, Genesis 3+.
    SUB:Deftech PF15TL+, DCM TB1010, Velodyne VA08BVX10. Pre: HK AP2500. Amps: BB175, Adcom GFA-535,555II, Rotel RB-990BX.

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default

    So what your saying is well any speaker/driver shipped to you, maybe has a 50/50 chance of getting there in working condition??? I don't think so.



    I've ordered speakers/drivers..for a bunch of speakers, Advents and Polk...guitar speakers..sorry they all work. They go thru the same UPS crap. I order 2 MW6511's..off of ebay..both of them have the same problem. There wrapped in enough bubble wrap to kill a moose...but both are stone dead and Completely FROZEN...I think NOT...if you really think they worked before they shipped them..i don't by it...

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jan 2012
    Location
    Denver
    Posts
    1,887

    Default

    Quote Originally Posted by naturallight View Post
    So what your saying is well any speaker/driver shipped to you, maybe has a 50/50 chance of getting there in working condition??? I don't think so.
    Not any but old Polk drivers are very prone to magnet shifts. There are few other brands like EPI (I think).
    That's why there is so much emphasis on epoxying the magnets.

    Most may arrive fine after shipping but quite a few suffer magnet shifts if you search threads here.

    But it may very well be that the seller sold them like this with magnet shift.
    Either way, it's bad for buyer as the only options are either to return and loose shipping or work with seller to get partial refund.

    Boston A400,VR950, DefTech BP10,, Klipsch Forte,KSP-400,KSF-C5,RF3,RC3.
    JBL L20t,L80t3, EPI 20+,T/E 280, Polk 4,4.5,5A,7C, KEF Coda III, Yamaha NS-690, Genesis 3+.
    SUB:Deftech PF15TL+, DCM TB1010, Velodyne VA08BVX10. Pre: HK AP2500. Amps: BB175, Adcom GFA-535,555II, Rotel RB-990BX.

  8. #8

    Member Sales Rating: (49)

    Join Date
    Jan 2009
    Location
    Wyred 4 Sound
    Posts
    11,236

    Default

    I shipped all the guts out of a set of 15tl's, drivers, passives, crossovers, in one box, packed to withstand a bomb, and everything survived the trip.

    Then another time I shipped two drivers the same way, and they didn't make it. I just refunded the money, it's a risk you take when you sell them..

    I bet I have about 50 spare drivers in my goodie closet..��
    No Way But The Hard Way, So Get Used To It!!!

  9. #9

    Member Sales Rating: (49)

    Join Date
    Jan 2009
    Location
    Wyred 4 Sound
    Posts
    11,236

    Default

    Quote Originally Posted by naturallight View Post
    So what your saying is well any speaker/driver shipped to you, maybe has a 50/50 chance of getting there in working condition??? I don't think so.



    I've ordered speakers/drivers..for a bunch of speakers, Advents and Polk...guitar speakers..sorry they all work. They go thru the same UPS crap. I order 2 MW6511's..off of ebay..both of them have the same problem. There wrapped in enough bubble wrap to kill a moose...but both are stone dead and Completely FROZEN...I think NOT...if you really think they worked before they shipped them..i don't by it...
    File with PayPal, and eBay, and don't settle for anything less then a full refund.. I won my case, different product but I still won, and didn't lose a dime, just a little time..
    No Way But The Hard Way, So Get Used To It!!!

  10. #10

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default

    Thanks Tool..I already filed with EBAY....like tell the seller the stuff dose not work thing.

    But i figured it would be..they say it did work before they shipped it..i say it does not..so didn't think i would get much out of this. It's 70 bucks..so not massive money here, which in truth that may be what there counting on. It may take months to get anything back...but what can you do.



    I've seen bad drivers before..but these 2....the voice coils have to be fried together..you can NOT move these at ALL. These speakers were just beat to crap with an under powered amp...there just a mess.

    Pretty much why they were sitting in the garbage......or given away. which is were they got them..at least from my guess.

  11. #11

    Member Sales Rating: (0)

    Join Date
    Jan 2012
    Location
    Denver
    Posts
    1,887

    Default

    Best of luck!
    My experience on bad ebay deal is that buyer pays return shipping but hopefully you don't loose any money and seller refunds full amount.

    Boston A400,VR950, DefTech BP10,, Klipsch Forte,KSP-400,KSF-C5,RF3,RC3.
    JBL L20t,L80t3, EPI 20+,T/E 280, Polk 4,4.5,5A,7C, KEF Coda III, Yamaha NS-690, Genesis 3+.
    SUB:Deftech PF15TL+, DCM TB1010, Velodyne VA08BVX10. Pre: HK AP2500. Amps: BB175, Adcom GFA-535,555II, Rotel RB-990BX.

  12. #12

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Location
    Pearland Texas 77584
    Posts
    2,007

    Default

    You said that they had some other listings, some MW6510?
    See if you can found out if the buyer was okay with those speakers.
    And by all means please let us know who this was so we don't get burned too.

  13. #13

    Member Sales Rating: (49)

    Join Date
    Jan 2009
    Location
    Wyred 4 Sound
    Posts
    11,236

    Default

    Keep in mind he had them listed MW6510's and they are MW6511's they are already not as listed, use the leverage where you can..
    No Way But The Hard Way, So Get Used To It!!!

  14. #14

    Member Sales Rating: (0)

    Join Date
    May 2006
    Location
    The Seasonally Frozen Wastelands
    Posts
    1,184

    Default

    It takes VERY LITTLE "magnet shift" to lock up a driver.

    Either the adhesive bond between magnet and speaker basket, or the adhesive bond between magnet and pole piece can be defective (or both.) We're talking thousandths of an inch.

    If you build a jig to re-align the pieces, you'll see that as soon as the adhesive bond breaks, the pole piece will "suck" magnetically to one side of the magnet, which effectively clamps the voice-coil. The jig is needed to prevent the natural mis-alignment.until the adhesive cures.

  15. #15

    Member Sales Rating: (0)

    Join Date
    Aug 2011
    Location
    Upstate S.C.
    Posts
    648

    Default

    Another possibility is they may have been checked fine by the seller but before they packed them up they dropped/ jarred them, etc. As you describe they look good so they may not have thought anything about it and packed them up. or they could just be total jerks and knew what was happening. No way to tell but worrying about it accomplishes nothing. Ebay tends to side strongly with the buyer and sellers benefit from taking care of their buyers. I had one issue on a purchase before and was issues a refund within a week and i didn't even want it or ask for it, just wanted the seller to fess up to the fact that their description was not accurate and would have been happy with an I'm sorry about that. The amount was not enough to stress over but E-bay took care of it quickly.

    Being 6511's i would try to remove the magnets and inspect if I really wanted the drivers, but filing a complaint or simply contacting the seller will prob resolve it for you if you want a refund or the like.

    good luck.

  16. #16

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default

    Well anything is possible. They could have been working when they sent them. They were packed like a brick you now what. To have both of them end up in the same condition, seems unlikely, but again i suppose anything is possible. I looked closely at the magnets, it's completely impossible to move them at all by hand. You would need a small gear puller with a lot of claws on it to get them off.

    Thats if you could get it off with out breaking it. Then you need the jig, to even have a chance at getting this back together right, which i don't have, nor the proper tools to build one. So to me it's pretty much unfixable. I sent them an email, told them the drivers were frozen. I have not heard back from them yet. They may just send back the money, and call it a day.

    I'm not sure the people really understood what they were selling. They seem to deal with antique's, hand woven baskets and stuff like that. Which would account for the massive packing.

    I doubt they were trying to screw anybody, they have a 100% rating, but they just don't deal in electronics or speakers for the most part.

  17. #17

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Location
    MAINE
    Posts
    3,217

    Default

    I would think if i was going to sell a item on the bay. I would want to know if it was ok. But i guess some people think dollar signs whenever they get something. Hope you get a good end to this here
    Randy
    HT-SDA1c Yamaha-RXV1-Denon-POA2200-HK DVD25-Cs400i-Monitor4's-Premier Acoustic150
    2ch-SDA2b-ADCOM GFA-555-565-600-555-YaQinCd2-Pioneer PL-630-AKAI GX210d
    Pioneer-SA9800-SG9800-CTF650-TXD1000-RT-909-Monitor11-Peerless
    Marantz-2252b-5025b-6300-YaQinCd1-TeacA4010s-Monitor7
    Yamaha-CR2040-Advent2-TeacA4010s-Monitor7

    Yamaha-CA810-CT810----- No Speakers Yet
    Marantz SR1000-Pioneer PM120 workbench set up

  18. #18

    Member Sales Rating: (0)

    Join Date
    Jun 2011
    Posts
    688

    Default

    Well i originally told these people the drivers were toast, but also said there really hard to come by.

    There first offer was, fine, send them back at my cost to ship them, and they would repay the

    original cost..which leaves me with the cost to ship them. To be honest i said..to cut you a deal as i don't want to ship these back....i will send you pics of these drivers with screwdrivers thru them, an toss them in the garbage. Just pay me the original cost of the speakers. Which is unfortunately were they belong..you can't fix these drivers 100%



    Now they sent an email to say NOW they will pay for both shipping costs. So i said fine, no problem, there already back in the shipping box.



    Now the problem is probably they don't believe me, but they also think there worth more money.



    So just a warning on this. If you see a pair of MW6511 on ebay with CRS + imprints on them don't buy them, they may listed at more then 70+ bucks..but there broke drivers....



    Why anybody would try and sell them again, or really why anybody would want them back..is beyond me..but this is EBAY...so just let this be a heads up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. IF, the drivers i just got on Ebay ARE MW6511's..then i'm happy
    By naturallight in forum Vintage Speakers
    Replies: 4
    Last Post: 06-30-2013, 03:36 PM
  2. SOLD Nice MW6511 SDA drivers
    By geppy1 in forum For Sale (FS) Classifieds
    Replies: 9
    Last Post: 07-10-2010, 07:25 PM
  3. Wanted MW6503 and MW6511 Drivers for SDA2B
    By fafner in forum Wanted (WTB) Classifieds
    Replies: 0
    Last Post: 04-30-2010, 09:15 AM
  4. WTB: 1 or 3 MW6511 drivers
    By TampaTwo in forum Wanted (WTB) Classifieds
    Replies: 0
    Last Post: 12-15-2007, 07:08 PM
  5. Locked 6-1/2 " drivers MW6511
    By wrich22 in forum Troubleshooting
    Replies: 7
    Last Post: 05-03-2007, 10:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts