Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2013
    Posts
    1

    Unhappy Crest 9001 amp problem

    Hello

    Last mounth i bought a crest 9001 amp..
    We used it and the sound was amazing!!!However yesterday i set up my soundsystem and the amp act strange..
    This is the problem: when i open 1 channel the amp plays louder then the 2 channels open.. if i close 1 channel while playing u can here the bass going louder.. if i open the 2de channel again the bass goes down..
    I tryed to play stereo and mono nothing make's a diffrence.. anyone has any cleu what this could be as i spend a lot of €'s on that second handed amp

  2. #2

    Member Sales Rating: (0)

    Join Date
    Jan 2009
    Location
    Rocky Top TN
    Posts
    402

    Default

    That's a balanced input amp. Tell us about what you're driving it with and about the cables and connections used if converting from unbalanced.

    Also, it has switching for modes on the amp. How do you have it set?

    CJ
    As seen on the AVS forum... "Radio Shack zip cord kicks butt."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Replies: 9
    Last Post: 04-15-2013, 08:24 PM
  2. Coat of Arms/Family Crest
    By tommyt21 in forum The Clubhouse
    Replies: 3
    Last Post: 02-08-2012, 03:22 PM
  3. Crown vs. Crest Audio vs. QSC Amps?
    By Serendipity in forum Electronics
    Replies: 16
    Last Post: 05-23-2011, 10:09 AM
  4. Need Help SDA CRS + problem....
    By xj4094dg in forum Vintage Speakers
    Replies: 1
    Last Post: 07-26-2009, 12:20 AM
  5. crest audio la-601
    By honda cber in forum 2 Channel Audio
    Replies: 4
    Last Post: 03-05-2008, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts