Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2008
    Posts
    10

    Default SDA speakers & ADCOM speaker selector problem

    Hello all
    I am having a problem with the use of SDA-2 speakers when hooked up to an Adcom 6 pair speaker selector.
    Here are the details
    There are 2 pair of speakers hooked up to the selector.
    A pair of Monitor 10's and a pair of SDA-2
    When the SDA interconnect is not connected everything is ok
    Each pair of speakers emits sound only when selected
    When the SDA cable is connected the SDA-2 work properly when selected
    When both pair are selected everything seems ok also
    When I select only the Monitor 10s a low level sound comes put of the SDA-2 pair as well
    That's the problem.
    INFO
    - All wiring is correct regarding L&R Channel & phase
    - The amp is solid state & is common ground
    - The selector is common ground
    - I have reversed the phase on the SDAs individually and at the same time with no change
    - I've swapped in a tube amp with no change except that volume from the SDAs might be a little louder

    Experienced advice most greatly appreciated.

    Edward (Eddie Spaghetti)

  2. #2
    Audiophile
    Member Sales Rating: (30)

    Join Date
    Mar 2006
    Location
    Seattle
    Posts
    11,183

    Default

    I'll have to think about this one more, but you are having a problem because the SDA effect used the negative binding posts, so that would be transmitted into anything else hooked up; including the speaker selector and other speakers. Are there any problems when the speaker selector is removed?

  3. #3

    Member Sales Rating: (0)

    Join Date
    Aug 2010
    Location
    central Jersey,08859
    Posts
    1,705

    Default

    Eddie,I also run a speaker selector w/3 sets of speakers.Now mine is a Niles sp- 6 zn selector w/ protection mode included.I also have an Adcom gfa 555 w/ newly slightly modded 87' SDA 2Bs. My other sets are DCM TF350s and ADC 303ax,all different and all work independently.Did you go direct from the amp w/ each set of speakers and just by pass the selector? If not then you find out whether it's your selector that's beat or a wiring issue w/ one of your sets of speakers,as I have found out sh$t happens and you just never know while moving things around.
    2chl- Adcom 555- NAD 1020a pre- JVC-QL-A200 tt- Denon 1940 ci cdp- Samson - 9 outlet- Niles - 6 zone spkr selector- DCM TF 350s- ADC 303ax- KLH 331- Polk Audio '87 SDA 2Bs w/ ic cable (Dynamat extreme, black hole-5- Mills 0.5 resistor, liquid nails, RDO- 194 tweeters, Larry's rings, Armaflex gaskets, stained walnut tops )

    H/T- Toshiba au40" flat- Yamaha RX- V665 avr- YSD-11 Dock- I-Pod- Klipsch #500HD Speaker set- Sony ce 375 5 disc carosel cdp-

    Nikko 6065 receiver- JBL J2060

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2008
    Posts
    10

    Default

    Thanks Jake and thanks leftwinger for your quick replies.
    I bypassed the speaker selector by running the Monitor 10s and the SDA2s directly off the Speaker A & B outputs respectively on the amp.
    Same issue
    When the Monitor 10s are on & the SDAs off there is a signal at the SDAs if the interconnect cable is connected.

    Now for a real surprise
    I swapped out the SDA2s for a pair of SDA-CRS.
    The problem went away.
    So now it seems it's time to diagnose the SDA2 problem
    E

  5. #5

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Location
    MAINE
    Posts
    3,210

    Default

    Wow. Thats odd. Cant wait to hear what this problem is.Good luck & hope its a easy fix
    Last edited by boston1450; 08-29-2013 at 06:10 AM.
    Randy
    HT-SDA1c Yamaha-RXV1-Denon-POA2200-HK DVD25-Cs400i-Monitor4's-Premier Acoustic150
    2ch-SDA2b-ADCOM GFA-555-565-600-555-YaQinCd2-Pioneer PL-630-AKAI GX210d
    Pioneer-SA9800-SG9800-CTF650-TXD1000-RT-909-Monitor11-Peerless
    Marantz-2252b-5025b-6300-YaQinCd1-TeacA4010s-Monitor7
    Yamaha-CR2040-Advent2-TeacA4010s-Monitor7

    Yamaha-CA810-CT810----- No Speakers Yet
    Marantz SR1000-Pioneer PM120 workbench set up

  6. #6

    Member Sales Rating: (0)

    Join Date
    Aug 2010
    Location
    central Jersey,08859
    Posts
    1,705

    Default

    Not an electrical engineer here and really don't take my advice I'm learning as I go also, but sounds like either your I/C cord connectors/blades or pins are grounding something out w/in the SDA 2s.It's very odd, but if they work w/o the cord w/ no problem then it can be with the dimensional x-over it's self on the left side? Maybe...

  7. #7

    Member Sales Rating: (0)

    Join Date
    Mar 2012
    Location
    MAINE
    Posts
    3,210

    Default

    Wonder--did they work before without a problem ? Is all contact with cord proper ? (Been hit or just bad contact- corrosion inside) Its gotta be in the speakers or cord if you change amps & it follows. I dont know diddly but hope ideas can help. Get out the meter
    Last edited by boston1450; 08-29-2013 at 07:16 AM.
    Randy
    HT-SDA1c Yamaha-RXV1-Denon-POA2200-HK DVD25-Cs400i-Monitor4's-Premier Acoustic150
    2ch-SDA2b-ADCOM GFA-555-565-600-555-YaQinCd2-Pioneer PL-630-AKAI GX210d
    Pioneer-SA9800-SG9800-CTF650-TXD1000-RT-909-Monitor11-Peerless
    Marantz-2252b-5025b-6300-YaQinCd1-TeacA4010s-Monitor7
    Yamaha-CR2040-Advent2-TeacA4010s-Monitor7

    Yamaha-CA810-CT810----- No Speakers Yet
    Marantz SR1000-Pioneer PM120 workbench set up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. SOLD Adcom GFS-4 speaker selector
    By carvcom in forum For Sale (FS) Classifieds
    Replies: 6
    Last Post: 11-04-2011, 10:57 AM
  2. Adcom 565 Pre Amp Selector Switch Cleaning
    By nap in forum Electronics
    Replies: 2
    Last Post: 09-27-2011, 07:09 PM
  3. Adcom GFS speaker Selector
    By dcmeigs in forum 2 Channel Audio
    Replies: 14
    Last Post: 06-30-2011, 01:10 AM
  4. Looking for Adcom GFS-4 speaker selector
    By muncybob in forum Wanted (WTB) Classifieds
    Replies: 1
    Last Post: 06-14-2011, 03:02 PM
  5. For Sale Polk CS-400, RDO-194s, and Adcom spaker selector
    By DaveMuell in forum For Sale (FS) Classifieds
    Replies: 12
    Last Post: 06-09-2010, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts