Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (0)

    Join Date
    Oct 2013
    Posts
    0

    Default Psw10 Subwoofer emitting strange sound

    Recently had to disconnect the sub to paint the room, was working fine. When I reestablished the subwoofer connection, the subwoofer emits a strange constant sound, sounds like ummmmmmmmmmm


    Subwoofer connection to receiver (sub pre-out)
    Y split cable to subwoofer
    Low pass set to 180
    Phase switch - have tried each position

    Am I doing anything wrong? Did something happen to the subwoofer?

    Thanks
    Dean

  2. #2

    Member Sales Rating: (0)

    Join Date
    Aug 2013
    Location
    Abbotsford BC
    Posts
    1,466

    Default

    Check to make sure you've fully inserted the RCA plugs everywhere along the chain of wire, sometimes a loose RCA cable can cause a ummmmmmmmmmm type of sound.
    Living Room Evolved
    Onkyo TX-NR717
    Parasound HCA-1200II > Polk Audio RTi A7 Black Front
    Polk Audio RTi A3 Black Rear
    Polk Audio CSiA6 Center
    Tannoy TS2.12 Sub
    Marantz CD6004
    Apple Mac Mini
    Apple TV 3rd Gen
    Sony PS3 160Gb/Microsoft XBox 360
    Insignia 55 inch 120Hz TV

    Bedroom
    Harman Kardon HK 3490/HK 3375
    A:Onkyo SKF-4800 Towers Black
    B:Polk Monitor (Model) 5 with Peerless Tweets
    Polk PSW108
    PS3 320Gb
    Insignia 39 inch 60Hz TV

  3. #3

    Member Sales Rating: (0)

    Join Date
    Feb 2011
    Posts
    44

    Default

    unplug the cable going into the back of the subwoofer, is the hum gone? possible ground issues from the receiver, y-cable, etc. worse case you could float it. are you using the exact same power outlets, locations, cables, etc as before?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help No subwoofer sound PSW10 with Pioneer SX-218-K
    By Wick777 in forum Basic Hookup/Wiring Questions
    Replies: 4
    Last Post: 07-13-2011, 04:39 AM
  2. My SDA-2 sound strange
    By Malcolm G in forum Troubleshooting
    Replies: 44
    Last Post: 04-27-2009, 08:48 PM
  3. I'm on the fence but my sound is strange...
    By mantis in forum Electronics
    Replies: 19
    Last Post: 01-04-2009, 08:03 PM
  4. Strange subwoofer noise....
    By shawn474 in forum Troubleshooting
    Replies: 4
    Last Post: 08-07-2007, 09:52 AM
  5. Denon 3801 -- strange whirring sound
    By jeberhart in forum Electronics
    Replies: 6
    Last Post: 05-19-2002, 07:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts