Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Location
    Cleveland, OH
    Posts
    15

    Default LSi15 tweeter spontaneously went dead.

    I've had the speaker for a week and half and yesterday I noticed there was no sound coming from the tweeter in the left channel. I called Polk and they were awesome, took my name & number and are shipping a new one out to me.

    Is there anything else that could have fouled up besides the tweeter? The mid-ranges & woofer are working fine, so i would assume it's not a problem with the internal cross-over?

    It's gonna be excruciating waiting 4 days for a part that will take 5 minutes to swap out.
    Mains: Polk LSi15
    Pre/Pro: Yamaha RX-V663
    Amplifier: Emotiva LPA-1
    Subwoofer: KLH ASW8-120b

  2. #2

    Member Sales Rating: (0)

    Join Date
    Sep 2004
    Location
    Xanadu
    Posts
    180

    Default

    Hello,
    Tweeter failure can almost always be directly related to high amount of very high frequency, odd-order distortion caused by overdriving the amplifier.
    Cheers, Jed

  3. #3

    Member Sales Rating: (0)

    Join Date
    Sep 2007
    Posts
    54

    Talking

    That means too loud lol.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Apr 2008
    Location
    Cleveland, OH
    Posts
    15

    Default

    UPDATE: new tweeter arrived yesterday. Still no sound. I installed it in the working speaker and it functions. Called Polk again and they are sending me a new crossover network.
    Mains: Polk LSi15
    Pre/Pro: Yamaha RX-V663
    Amplifier: Emotiva LPA-1
    Subwoofer: KLH ASW8-120b

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Need Help PSW 10 Dead
    By Everetts in forum Troubleshooting
    Replies: 4
    Last Post: 05-15-2008, 09:41 PM
  2. Tweeter hiss: lsi15 = hiss, lsi9 = no hiss
    By SlowcarIX in forum Speakers
    Replies: 27
    Last Post: 03-28-2008, 08:29 PM
  3. 22 Dead at VT
    By Demiurge in forum The Clubhouse
    Replies: 137
    Last Post: 04-19-2007, 10:20 AM
  4. CSi40 Tweeter is dead
    By doggie750 in forum Troubleshooting
    Replies: 5
    Last Post: 08-11-2006, 02:13 PM
  5. LSi15/LSiC/LSi9 or LSi15 for rear?
    By infinitiqx4 in forum Speakers
    Replies: 14
    Last Post: 04-25-2003, 01:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts