Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Location
    Minnesota
    Posts
    529

    Default TT help needed. Sony PS 210

    This is one of my nicer TT's and sounds great . Seems to only start to spin platter when it is a quarter of an inch into first song? Any and all help would be greatly appreciated. I am starting to get more serious about vinyl . I bought a scale and protractor to finally start a proper set up. Thanks. Darryl

    Pioneer Elite SC 63
    SDA SRS 1.2 front
    Rti12 rear
    FXiA6 sides
    Emotiva XPA 3
    Adcom GFA 555
    CSiA6 center
    PSW505 Subwoofer
    Original PS3 60G
    Oppo DV981HD cd transport
    Mitsubishi 73 rear projection
    Sanyo DC Servo player TP 727 turntable
    Monster HTS 5100MKII
    TheBlaze
    MIT MH-750 cables

  2. #2

    Member Sales Rating: (0)

    Join Date
    Dec 2012
    Location
    Great White North
    Posts
    1,157

    Default

    Hi Dabutcher..
    Did this just start happening?
    Does the arm feel a little loser than before?
    Might need an adjustment under the arm..
    VTL Compact 100 mono blocks, Casta Acoustics Model A's, VTL 5.5 Preamp,Audio Note L3 Phono Stage with audio Note AN-S2 Step Up,HiDiamond H5 Speaker Cables,McCormack DNA 500 ,Pro-Ject Xtension 10 TT/Technics SL-1200Mk2,Ortofon Cadenza Red/

  3. #3

    Member Sales Rating: (0)

    Join Date
    Jun 2012
    Location
    Pearland Texas 77584
    Posts
    1,997

    Default

    Yea it needs an adjustment with the shut off, it thinks it is at more than 6 inch radius from the center spindle

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Location
    Minnesota
    Posts
    529

    Default

    Been doing that since I bought it.

  5. #5

    Member Sales Rating: (2)

    Join Date
    Jun 2004
    Location
    New England
    Posts
    8,284

    Default

    Quote Originally Posted by PolkieMan View Post
    Yea it needs an adjustment with the shut off, it thinks it is at more than 6 inch radius from the center spindle
    Well, either the shut off or the turn on, methinks! :-) Most Japanese tts of that era had a microswitch that started the platter as the arm is swung from the rest position towards the platter. It should turn on just before the stylus crosses over the threshold of the platter. Presumably one (or more) of the position sensing switches needs to be adjusted.

    I just checked www.vinylengine.com and they don't have any docs for this particular Sony (nor am I familiar with this particular tt)... I'd suggest downloading a few of their Sony DD tt service manuals and peruse the instructions therein for adjusting the position sensors/microswitches. I imagine (I guess that I hope) you'll be able to figure out the procedure for this tt by analogy.
    all the best,
    mrh

  6. #6

    Member Sales Rating: (6)

    Join Date
    Apr 2008
    Location
    GA
    Posts
    2,203

    Default

    There may be an adjustment screw for this. On my Sony PS-X75 Biotracer table there is a small screw located within an access port on the top of the plinth near the tone-arm. There is a rubber plug that covers the access port so the adjustment screw is not readily accessible. Simply remove the rubber plug and the screw (standard slot) is revealed through the access port You can turn the screw so that it adjusts where the tonearm falls on the record starting playback during automatic mode. Your particular table may have a sensor that starts the platter only after the tonearm gets in the proper lead-in position in automatic mode. Have you tried operating the table manually and does it still do this when you operate manually?

    Edit, doesn't look like you can start the platter manually does it? I think is has to be either an adjustment issue as discussed above or a sensor that starts the platter may be faulty. Oh one other thing, on my Biotracer if the VTA of the tonearm is not set-up properly with the tonearm being parallel or close to parallel to the record surface during operation, the tone-arm will not operate during autostart mode. It's a protective feature to keep from damaging the stylus. Check your tone-arm level and make sure it is parallel to the record during playback. That may be throwing the autostart sensor for the platter out of whack.
    Last edited by Dawgfish; 11-06-2013 at 10:54 AM.

  7. #7

    Member Sales Rating: (0)

    Join Date
    Jan 2010
    Location
    Minnesota
    Posts
    529

    Default

    Went into the back and activated the switch a bunch of times and moved lever back and forth and now it seems to start at the right spot. Thanks for the help. D

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Replies: 4
    Last Post: 12-06-2011, 02:17 AM
  2. remote needed for Sony CDPCX355
    By halo71 in forum Electronics
    Replies: 5
    Last Post: 01-03-2011, 03:07 PM
  3. Help needed, Sony Receiver STR-DA5300ES
    By robbie p in forum Electronics
    Replies: 1
    Last Post: 04-05-2010, 09:09 AM
  4. Sony preamp help needed
    By halo71 in forum Electronics
    Replies: 3
    Last Post: 01-24-2010, 11:54 AM
  5. Need Help Turntable (Sony PS-LX63P) info needed
    By Felipero in forum Electronics
    Replies: 6
    Last Post: 03-10-2009, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts