Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    poscamry
    Guest

    Question poweracoustik amps

    Has anyone had any problems, or heard anything about PowerAcoustik amps, namley the LT980/2. I have one in my car, and this is the second time its done this to me, it will turn on, then dim out, giving nothing to my subs. All connections are fine, the battery is fine. just one day, well twice now, it just started this, and the last time just randomly started up again. any thoughts?

  2. #2
    NoSwapMeet
    Guest

    Default

    Don't buy swap meet amps

  3. #3
    poscamry
    Guest

    Default umm...no

    its not, it was brand new, thanks...

  4. #4

    Member Sales Rating: (4)

    Join Date
    Dec 2002
    Location
    Denial...it's in Egypt.
    Posts
    12,729

    Default

    That sounds like either a bad transformer or something is causing power protection circuitry to kick in. Unfortunatly, there is not much of a good way to test it. You might want to find a local dealer who deals with Power Acoustik stuff. They may be able to help you troubleshoot or test it on a bench. They may even beable to repair it and save your investment. Otherwise, I'd call Power Acoustik and see what they could od about it.

  5. #5
    poscamry
    Guest

    Default

    well i got it through some friends who own a dealer near me. so today i brought it in, swapped it out for a brand new one, hooked it up in the parking lot, and same problem. Ive already checked the fuses, checked the power/ground/remote turn one wires. The only thing i have yet to check is the rca cables. I was also told that the little wires that go from the center of the sub to the post, sometimes touch the basket, causing the whole thing to short out, but i dont want to have to rip them out, any other thoughts?

  6. #6

    Member Sales Rating: (4)

    Join Date
    Dec 2002
    Location
    Denial...it's in Egypt.
    Posts
    12,729

    Default

    Nope, I'd check all those connections again and pull those speakers. Somethings up, you are grounding out somewhere.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts