Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2004
    Posts
    6

    Default Fix or upgrade 5yr old PSW300

    I have a nearly 5yr old PSW300 sub that is part of a still functioning RM7300 surround systems. Still sound great, but the sub will rattle when driven hard. How do I tell if the woofer or amp is the problem?

    Next question is it worth fixing or upgrade to a new model?? Suggestion are welcome!

  2. #2

    Member Sales Rating: (2)

    Join Date
    Sep 2003
    Location
    Kansas
    Posts
    7,522

    Default

    Sounds like a perfectly good reason to let the upgrade bug bite!

    :D

  3. #3
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,846

    Default

    Hello Hosier,
    Since you've indicated you've owned the unit less than five years you would:
    1). remove the power cord from the wall outlet.
    2). remove the 12 Phillips head screws from around the circumference of the amplifier input plate.
    3). the amplifier module will pull forward away from the enclosure, there is a plastic housing over the amplifier components with wires leading to the 10" driver. These can be wriggled and removed from the driver's terminals.
    4). the four screws holding the driver can be removed and the driver will then pull out of the cabinet.
    5). send to: Polk Audio, 2550 Britannia Blvd., Suite A, San Diego, CA 92154. Please include a short note giving us your name and address and a copy of your sales receipt.
    Regards, Ken, Polk

  4. #4

    Member Sales Rating: (0)

    Join Date
    May 2004
    Posts
    6

    Default

    Ken,

    Thanks for the reply. I double check the sales receipt and the the sub is over 5yrs old - was purchased Aug 1998. Hope the offer still applies???

  5. #5
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,846

    Default

    Hello,
    Email me at kswauger@polkaudio.com and I'll be happy to help out.
    Ken

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts