Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Member Sales Rating: (1)

    Join Date
    Sep 2004
    Location
    Northern Virginia
    Posts
    201

    Default Sat TV and Ground Loop Hummmmmm

    I figured I'd let anyone know that is having problems with hum from a cable or sat dish (I have DirecTV) that I found a much cheaper solution than the Jensen electronics ground loop isolators that cost $50 to $100.

    I had some nasty buzz coming through my LSI7s when I added a couple of Outlaw M200 monoblocks to my setup.

    I had a little trouble finding any info on satellite TV setups causing ground loops and hum. No shortage of info blaming cable lines, though. I eventually traced the source to the dish rg6 cables and bought 2 "Xantech 634-00 Ground Breaker" isolators for $18 shipped from a buglar alarm retailer called Bass Home . Since I have two tuners on my DirecTivo, I got one for each feed.

    Like I said, these things are cheap as heck and work as well as products that are 5 times the price.
    Hope this helps someone!

    Rob
    Yamaha RX-V1500 // Outlaw Audio M200 (x2) Panasonic TH-52PZ700U
    Sony DVP-NS715P // Sony Playstation3 // Roku Soundbridge M1000[/color]
    Polk LSi15 (w/Monster Z2 Wire) // Polk LSiC // Polk LSi7 // Velodyne DLS-3500

    Workshop Rig: Creek 4330 // Technics SL-P310 // Cambridge Soundworks Ensemble 2

  2. #2

    Member Sales Rating: (40)

    Join Date
    Jul 2001
    Location
    North Texas
    Posts
    18,401

    Default

    Great find Rob, thanks for sharing!

    Cheapest I had found so far was at PE for $9.80 each, but you've got even that beat.

    Cheers,
    Rooster
    Last edited by RuSsMaN; 10-23-2004 at 10:13 PM.
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.

  3. #3

    Member Sales Rating: (1)

    Join Date
    Sep 2004
    Location
    Northern Virginia
    Posts
    201

    Angry I take it all back

    OK- It's been a few days and my TIVO hasn't recorded anything. Turns out, yeah, the humm is gone, but so is the sat signal! Nice.

    :o Crap. And I was so excited.

    Rob
    Yamaha RX-V1500 // Outlaw Audio M200 (x2) Panasonic TH-52PZ700U
    Sony DVP-NS715P // Sony Playstation3 // Roku Soundbridge M1000[/color]
    Polk LSi15 (w/Monster Z2 Wire) // Polk LSiC // Polk LSi7 // Velodyne DLS-3500

    Workshop Rig: Creek 4330 // Technics SL-P310 // Cambridge Soundworks Ensemble 2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts