Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Posts
    10

    Default MOMO Tweeters makin a popping sound!!

    I've had the MOMO tweeters for about a month and i have a fosgateamp pushhing them but all of a sudden the tweeters are making a popping sound......anyone with any info please respond!!!

  2. #2
    Polk Customer Service
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    725

    Default

    Nunzio,
    If the MM400's are making a "popping" sound, then I would
    suspect that they are being driven too hard or the amp driving them may need service. Does this occur at higher volume levels or does this happen all of the time?? Do they sound "OK" at lower volume settings?? If you have any questions feel free to call us at 800-377-7655 between the hours of 9 AM to 6 PM Eastern time. Let us know and we will be glad to help

    Thanks,
    Kim

  3. #3

    Member Sales Rating: (0)

    Join Date
    Sep 2008
    Posts
    1

    Default Polk DB1001 Tweeters

    i recently bought some tweeters during the weekend and recently noticed that one of them is constantly popping regardless what the volume is. it still sounds awesome and works fine but constantly pops. i have a amp and crossover hooked up to power the 2 tweeters and the other 2 speakers that are in my door but only this one tweeter is popping. please help

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,825

    Default

    Wow. This has to be the oldest thread Ive ever seen drudged up.

    What kind of popping? If its a "staticky" sound then you could have some speaker wire touching bare metal somewhere.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  5. #5

    Member Sales Rating: (1)

    Join Date
    Jun 2002
    Posts
    3,860

    Default

    It could also be electrical interference between something else in your cars electrical system. My tweeters are more staticy with the fan (inside fan not the fan in the engine) on then when it's off. Not sure why, but whatever.
    SDA 2B
    Carver m0.5t
    AMC pre
    Cobalt Cables

  6. #6

    Member Sales Rating: (0)

    Join Date
    Dec 2003
    Location
    Chattanooga, TN
    Posts
    11,825

    Default

    Quote Originally Posted by Airplay355 View Post
    It could also be electrical interference between something else in your cars electrical system. My tweeters are more staticy with the fan (inside fan not the fan in the engine) on then when it's off. Not sure why, but whatever.
    My first guess would be that youve got a ground problem either a loose or bad ground or outright ground loop.
    polkaudio sound quality competitor since 2005
    MECA SQ Rookie of the Year 06 ~ MECA State Champ 06,07,08,11 ~ MECA World Finals 2nd place 06,07,08,09
    08 Car Audio Nationals 1st ~ 07 N Georgia Nationals 1st ~ 06 Carl Casper Nationals 1st ~ USACi 05 Southeast AutumnFest 1st

    polkaudio SR6500 --- polkaudio MM1040 x2 -- Pioneer P99 -- Rockford Fosgate P1000X5D

  7. #7

    Member Sales Rating: (1)

    Join Date
    Jun 2002
    Posts
    3,860

    Default

    Possible...but I drive a subaru outback now so not my problem anymore ;)
    SDA 2B
    Carver m0.5t
    AMC pre
    Cobalt Cables

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts