Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default what causes a sub amp to shut down?

    LOL, No not my dear SVS thank goodness...

    I picked up a 10" KLH sub at the flea market this weekend, in "works great" condition according to the seller... It does work, but when i increase sub plate amp volume or pre/receiver volume it makes a noise in the woofer(low sound) and cuts off... I can flip it to off and back on and it comes right back on, unless the volume is still high...

    what i did do first, cleaned the volume and x-over pots with cleaner, retouched several solder connections on the larger parts to make sure it wasnt cold solder joints.. checked to see that the woofer wasnt blown,

    any idea's... its in good shape and i hate to just toss it.. nor spend 100 to fix it with a new plate amp
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  2. #2

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    any idea's ?
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  3. #3
    Polk Engineer
    Member Sales Rating: (1)

    Join Date
    Apr 2004
    Location
    Annapolis, MD
    Posts
    1,441

    Default

    You're sending too much current to the woofer (possibly from clipping). This probably does one of a couple things:
    -there's a thermal protection circuit that turns on and shuts down the amp
    -there's an overcurrent protection circuit that shuts down the amp

  4. #4
    Old School
    Member Sales Rating: (1)

    Join Date
    Dec 2002
    Location
    Higher & Dryer, Texas
    Posts
    10,176

    Default

    Possibilities...

    Try contacting KLH:
    http://www.klhaudio.com/
    More later,
    Tour...
    Vox Copuli
    Better to remain silent and be thought a fool, than to open your mouth and remove all doubt. - Old English Proverb

    "It's easy to get lost in price vs performance vs ego vs illusion." - doro
    "There is a certain entertainment value in ripping the occaisonal (sic) buttmunch..." - TroyD
    "Death doesn't come with a Uhaul." - Dennis Gardner

    Rebuilding Maggie 2-ch & Amazing 2-ch... Building 2-ch "wall"... Figuring out the HT

  5. #5

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    Sitting pretty in AZ
    Posts
    1,148

    Default

    blown sub ??? causing a dead short which would cuase the amp to shut off
    Speakers:
    Definitive BP7001sc mains
    Definitive C/L/R 3000 center
    Polk RT800i's rears
    Definitive supercube I Sub
    Audio:
    Onkyo TX-NR3010
    Adcom GFA 7500
    OPPO BDP-103 CD, SACD, DVD-A
    Video:
    Mitsubishi WD65837 DLP
    OPPO BDP-103 Bluray
    Directv x's 2

  6. #6

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    i already e-mailed KLH, But thanks.... will call shortly if they don't e-mail back,

    the woofer works at low volumes, its not blown... Its not getting hot after 15 seconds of use.... Its from a cold start. I just got it 2 days ago so i havent spent alot of time with it. I picked it up dirt cheap and wanted to fix it if it was cheap...

    Its not a great loss if its unfixable, and a cheap sub when it was new, kinda a project... got no money in it hardly and would make a cool second room sub.. or my brother in-law also needs a sub... so it will most likely just go to him if i fix it....
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts