Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
Results 1 to 12 of 12
  1. #1

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default does anyone have any rca caps (ie:cardas caps)

    Looking for 2 rca non shorting caps.. for my dodds extra outputs...

    or a link to somewhere that doesnt require a dozen order.. only need 2
    Last edited by faster100; 05-12-2005 at 01:30 PM.
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  2. #2

    Member Sales Rating: (6)

    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    16,228

    Default

    disregard.
    Last edited by steveinaz; 05-12-2005 at 01:04 PM.

    Source: Squeezebox Touch/CIA Power Supply
    DAC: Benchmark DAC/PRE
    Linestage: Placette RVC Passive
    Power Amp: Parasound HCA-1500A
    Speakers: Harbeth Compact 7ES-3 Monitor
    Subwoofer: SVS PB12-NSD

  3. #3

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    Ok :)

    or a link to some that doesnt require you buy a case of them..


    Edit, i found a site that sells singles/// now all the Cradas are non shorting right? don't wanna short my outputs
    Last edited by faster100; 05-12-2005 at 01:59 PM.
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  4. #4

    Member Sales Rating: (13)

    Join Date
    Jul 2003
    Location
    The Beautiful Central Oregon Coast
    Posts
    4,039

    Default

    Yeah, they're just caps. Are you getting them from Moon Audio?
    Last edited by dragon1952; 05-12-2005 at 06:22 PM.

  5. #5

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    so will it do anything to help? or just a voodoo doo doo thing..

    here [url]http://www.linearinterconnects.com/[/url] is where i found them
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  6. #6

    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    10-uh-see
    Posts
    1,300

    Default

    Voodoo doo doo.......now thats some scary ****.:D
    "Its worked so far but we're not out yet."
    "Hey big man let me hold a dollar"

  7. #7

    Member Sales Rating: (13)

    Join Date
    Jul 2003
    Location
    The Beautiful Central Oregon Coast
    Posts
    4,039

    Default

    [QUOTE]so will it do anything to help? or just a voodoo doo doo thing..[/QUOTE]

    What are you trying to help? They will definitely keeps worms and bugs out :D

  8. #8

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    interference, cross talk, stuff like that...
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  9. #9

    Member Sales Rating: (13)

    Join Date
    Jul 2003
    Location
    The Beautiful Central Oregon Coast
    Posts
    4,039

    Default

    I would certainly think they would help in those areas. I don't see what could possibly just be voodoo about that. Now the people who report increase in SQ just as a result of using these I would wonder about. Besides, at only around $2 apiece you don't have a whole lot to lose anyway and you'll at the least keep the dust and other rif-raff out. Plus I think they look pretty nice.
    Last edited by dragon1952; 05-13-2005 at 12:12 AM.

  10. #10

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    actually i have a hum, checked the pre and its dead quiet on the meter, so i'm just going down the cheap road to eliminate all the other interferences, I know it wont stop hum but any efi/rfi is a start... I'm not worried about the money, for 2 bucks but i dont wanna order, pay shipping for them to do nothing but look pretty.. LOL

    Thanks though for the insight
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  11. #11

    Member Sales Rating: (13)

    Join Date
    Jul 2003
    Location
    The Beautiful Central Oregon Coast
    Posts
    4,039

    Default

    Is the hum coming out of the speakers? That could mean a ground loop. If it started with the addition of the ELP I'd try a different interconnect between it and your amp and see if that solves the problem. What interconnects are you using? Or disconnect the source(s) from the preamp and see if it goes away.
    BTW, I just added the ELP to my system and I haven't had any issues at all.
    Last edited by dragon1952; 05-13-2005 at 12:52 PM.

  12. #12

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    I tried with no inputs, i'm useing signal cable and Mit with a M1000 series monster cable for the tuner... yes the hum is out the speakers... soon as i take the Elp off mute.. however i shorted the inputs and tested for voltage on the outputs and its dead 0's zero's so its not the pre.. It must be this ****ty electric service we have.. house was even rewired a year ago.. complete rewire and box outside.. who knows
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts