Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Member Sales Rating: (5)

    Join Date
    Jun 2003
    Location
    northern nj
    Posts
    6,608

    Default WTF did i do wrong?!?

    i was listening to my 2 channel. but i turned the Radii preamp (tubes) off and heard a buzzing in my amplifier (the carver). Actually, the carver allways has a low buzz, but the buzz got louder for about a second when i turned the preamp off. I then turned it on again after a couple of seconds, and the speakers made a low rumble/thump, I looked at the carver and the protection circuit light was on. I quickly turned the entire system off via switch on my surge protector. I waited a little bit and then powerred it up like normal. power strip switch on, then preamp, then wait 20 seconds (per Russman) and turn the amp on. Amp made same low buzz it allways made. system worked fine like allways (which is good news)

    but what happenned? i only want to know so i learn and avoid in the future.

    It shouldnt be related from what i know, but i did switch the tweeters in my SDA 1B's to the replacement tweeters just before i initially turned my system on. I listened for 15 minutes when i turned the preamp off the first time as noted above.

    as i said in title ........ WTF did i do?!?!?!?!?!?!?!
    Theater - Polk LSi15, LSiC, LSi9 speaks, DIY Sub (142.5L box, SVS plus driver, 500 Watt plate amp)...Outlaw 990 pre/pro, Carver TFM45, 2 X Outlaw M200 . Rotel RB980 . PS3, Monster 3600 power center

    2 Channel -
    Anthem Pre 2l, Jolida JD100 CD player, CAL Sigma DAC, Carver m4.0, Polk LSi9 w external modified Crossovers (thanks Trey!)

  2. #2

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    always turn the amp off first then the pre, also make sure the pre is on first and for a few before you turn the amp on, i dunno what happened... but make sure pre on, amp on, on the power up and reverse to power off... amp off pre off.... hope everything is ok
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  3. #3

    Member Sales Rating: (40)

    Join Date
    Jul 2001
    Location
    North Texas
    Posts
    18,401

    Default

    Exactly what Cliff said.

    Turn the pre on FIRST - let the plate voltage come up and stabilize on the tubes (about 20-30 seconds), THEN turn the amp on.

    Turn the amp off FIRST - and on the Carver, give it 20 or so seconds also for the caps to discharge, THEN turn the preamp off.

    As far as the low buzz goes, try the ground lift switch on the rear of the Radii, next to the IEC. DO NOT CHANGE IT WHILE POWERED UP. Shut the rig down as above, switch the ground lift toggle on the rear, start the powerup sequence as above.

    See if that makes a difference.

    Cheers,
    Russ
    Last edited by RuSsMaN; 05-13-2005 at 09:02 PM.
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.

  4. #4

    Member Sales Rating: (5)

    Join Date
    Jun 2003
    Location
    northern nj
    Posts
    6,608

    Default

    roger wilco

    was actually following that procedure, a brain fart caused me to deviate from it. that will not happen again.

    the system, thank merciful Christ, is ok. just got done listening to it.


    Russ, will definitly try that. WHILE THE SYSTEM IS OFF :D


    thanx for the help guys, good advise as usual


    Lou
    Theater - Polk LSi15, LSiC, LSi9 speaks, DIY Sub (142.5L box, SVS plus driver, 500 Watt plate amp)...Outlaw 990 pre/pro, Carver TFM45, 2 X Outlaw M200 . Rotel RB980 . PS3, Monster 3600 power center

    2 Channel -
    Anthem Pre 2l, Jolida JD100 CD player, CAL Sigma DAC, Carver m4.0, Polk LSi9 w external modified Crossovers (thanks Trey!)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts