Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (0)

    Join Date
    Apr 2002
    Location
    Bakersfield, CA
    Posts
    307

    Default component question

    I just hooked up one of my 5x7 Alpine Type R components in my car. I hooked them correctly to the crossover and straight to the factory deck. The deck is running I figure about 15x4. The speakers are rated at 60 watts a piece RMS. Now when I turn the bass up the Alpine woofer distorts and pops. Is this just because of the crossover setting? Or Possibly the lack of power? I had some CDT Audio components hooked to my factory deck in my old truck when I sold it and I could turn up the bass all the way and get very little distortion. Also, I know the positive and negative are hooked up correctly, and the speaker is nice and tight in the speaker pod in the door... which is air tight.
    "The Big C"

  2. #2

    Member Sales Rating: (1)

    Join Date
    Mar 2004
    Location
    College Station, TX
    Posts
    7,175

    Default

    im sure its because youre running it off the deck, grab an amp and throw it in the mix, itll really bring em alive
    -Cody
    Music is like candy, you have to get rid of the rappers to enjoy it

  3. #3

    Member Sales Rating: (1)

    Join Date
    Jun 2005
    Posts
    619

    Default

    Yeah that is your problem trying to run components on a deck. All you need to do is buy that little v-power Alpine 4 channel amp. It is only 199.00 and you can pick one up at BestBuy. It is rated at 40x4 or 100x2 and has decent sound quality in a small package.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    MD
    Posts
    678

    Default

    Quote Originally Posted by C-Man
    Now when I turn the bass up the Alpine woofer distorts and pops...
    Don't do that

  5. #5

    Member Sales Rating: (0)

    Join Date
    Oct 2003
    Posts
    278

    Default

    ^ its always the simplest answer... lol
    Picking ones nose signifies a strong sense of self discovery :)

    System in the works: ;)
    PP 6V6 with 12ax7 pre ~ 20 watts
    15" Jensen MOD 8ohm ~ 97db SPL
    DiMarzio HS3 and/or Tone Zone S

  6. #6

    Member Sales Rating: (0)

    Join Date
    Apr 2002
    Location
    Bakersfield, CA
    Posts
    307

    Default

    Thanks Thom, you're so helpful... lol
    That's what I figured, I still have my Zapco 200 I'm gonna throw on there soon, just gotta find time to put it all together.

    Chris
    "The Big C"

  7. #7

    Member Sales Rating: (0)

    Join Date
    Nov 2003
    Location
    Dayton, OH
    Posts
    3,459

    Default

    yep, turning your bass too far up will clip it, no matter what else you have going on... a need for more bass clearly indicates the need for a sub :p
    It's not good, very fundamentally simply not good. - geolemon

    "Its not good enough until we have real-time fearmongering. I want my fear mongered as it happens." - Shizelbs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts