Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Member Sales Rating: (0)

    Join Date
    Dec 2005
    Location
    Mile High
    Posts
    3

    Default Polk Audio Sub Power problem...

    Hello

    I recently bought a used Polk Audio Powered Sub PSW 150 in great shape and took it home, plugged it in (red pwr. light on back confirmed pwr.), the sub easily hooked right in to the right side Rear Channel of my system, and after a few adjustments, added a nice bottom to my rear array speakers in my rear channel.

    The next morning there was no power. The red pwr. light was out and I wasn't getting a signal through the sub. Now, no matter where I plug it in, it won't light up and I'm getting no signal.

    IF anyone has any insight as to why it would suddenly shut down, please let me know. I'm certainly no electrician but do have the ability to check a few things out if anyone has any ideas.

    Thanks in advance.
    Great forum you have here!
    Stickwork
    Attached Images  

  2. #2
    Polk Engineer
    Member Sales Rating: (1)

    Join Date
    Apr 2004
    Location
    Annapolis, MD
    Posts
    1,441

    Default

    Check fuse.

  3. #3

    Member Sales Rating: (0)

    Join Date
    Dec 2005
    Location
    Mile High
    Posts
    3

    Default

    So, I have to pull the back plate off to get to a fuse?
    Thanks for your reply.
    Stickwork

  4. #4

    Member Sales Rating: (0)

    Join Date
    Dec 2005
    Location
    Mile High
    Posts
    3

    Thumbs down fuse changed - no change

    BKnaus - I opened up the back, found the fuse and matched it up to a new one.
    Still, no power light.
    Any other ideas?
    Thanks
    Stickwork

  5. #5
    Polk Engineer
    Member Sales Rating: (1)

    Join Date
    Apr 2004
    Location
    Annapolis, MD
    Posts
    1,441

    Default

    Call up customer service :)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts