Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Jan 2006
    Posts
    33

    Default Problem with SRS 1.2

    Hi,

    I am currently facing problem with my SRS 1.2 . I face intermittent for
    the bass on the left speaker most of the time. It just goes off but the
    tweeters will just be sounding. What I did was apply pressure on the
    banana plugs to the binding posts and the bass came back on . I
    thought was some loose connections of the speaker wire on the banana
    plugs, but it wasn't the case. They were screwed on tight without doubt.
    Anyone face similar problem as I did ? How do I solve this ? Appreciate
    the help , thanks .

  2. #2
    Old School
    Member Sales Rating: (1)

    Join Date
    Dec 2002
    Location
    Higher & Dryer, Texas
    Posts
    10,176

    Default

    Are your 1.2's bi-wired or single with jumpers?

    If single, are you going into the upper or lower pair of speaker posts?
    More later,
    Tour...
    Vox Copuli
    Better to remain silent and be thought a fool, than to open your mouth and remove all doubt. - Old English Proverb

    "It's easy to get lost in price vs performance vs ego vs illusion." - doro
    "There is a certain entertainment value in ripping the occaisonal (sic) buttmunch..." - TroyD
    "Death doesn't come with a Uhaul." - Dennis Gardner

    Rebuilding Maggie 2-ch & Amazing 2-ch... Building 2-ch "wall"... Figuring out the HT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts