Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 3 of 3

Thread: Psw150

  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2002
    Posts
    83

    Question Psw150

    My PSW150 start humming, please advice how to fix this problem, this problem just started about 2 weeks, never happen before.

    Thanks for you help

  2. #2

    Member Sales Rating: (14)

    Join Date
    Jul 2001
    Location
    Pa
    Posts
    13,547

    Default

    you could have a bad grounding problem or the cable is becoming a antenna.
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.

  3. #3
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,850

    Default

    Hello,
    Welcome to the Forum, I'm sorry there's a problem with your system. A few basic trouble shooting items to check. What happens to the humming if you disconnect all of the incoming cables/wires (not the AC power cord, of course) from the sub-woofer? This will help determine what might be the cause. If the sub-woofer continues to hum, give me a call at 1-800-377-7655 extension 891 and I'm sure I can help.
    Regards, Ken Swauger

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts