Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 4 of 4

Thread: 6 1/2" coaxials

  1. #1

    Member Sales Rating: (0)

    Join Date
    Mar 2006
    Posts
    1

    Default 6 1/2" coaxials

    Hey all,

    I just bought 4 60watt RMS DB650 speakers and an 18watt RMS, per channel, Alpine head deck. The Alpine is very nice and allows me to adjust the bass frequencies from 60HZ to 120HZ and also allows me to adjust the band width. I have it set at 100HZ with a very narrow band width and have the bass turned down low, yet I still get distortion out of my speakers when the Alpine is turned up only half way. So, I don't get it. I have the bass turned down, the frequency set high at a narrow bandwidth, the Alpine puts out only 18RMS watts and my speakers can take 60RMS watts. It's a straight forward connection, very simple. So, why am I getting distortion when my head unit is turned only half way up? I would think that the speakers would be plenty-o-plenty powerful and the bass frequencies are turned way up. I just don't get it. Does anyone have any idea what could be wrong?

    Thanks,

    Tom

  2. #2

    Member Sales Rating: (55)

    Join Date
    Jul 2001
    Location
    Exit 5 on the Jersey Turnpike
    Posts
    12,063

    Default

    Try the car stereo portion of Club Polk's forums. That's where the car stereo discussions, questions, AND answers are.

  3. #3

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    OZ
    Posts
    1,579

    Default

    Quote Originally Posted by busa01
    I just don't get it. Does anyone have any idea what could be wrong?
    My guess is the flux capacitor is shot.

    BTW: Welcome.
    polkaudio speakers: SDA-SRS-2.3 (modified) SDA-2B SDA-CRS+ RT3000p CS400i LF-14 Monitor 7B

  4. #4

    Member Sales Rating: (0)

    Join Date
    Feb 2006
    Posts
    567

    Default

    hey man..you're in the wrong section here...but you gotta amp those puppies...trust me..i don't have a speaker in my car that runs off the H/U. Everything is amped..and i can't distort a speaker in my car no matter how high i turn the volume...do it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Powering Momo components and coaxials
    By Rogue Torino in forum Car Audio & Electronics
    Replies: 10
    Last Post: 02-22-2004, 04:55 PM
  2. looking for 6 1/2" drivers
    By ohskigod in forum Flea Market
    Replies: 5
    Last Post: 06-21-2003, 03:27 AM
  3. Question For Polk (coaxials)
    By phuz in forum Car Audio & Electronics
    Replies: 5
    Last Post: 03-01-2003, 04:26 PM
  4. 4 X 6 coaxials
    By RAMENANDSPAM in forum Flea Market
    Replies: 0
    Last Post: 02-25-2002, 12:07 PM
  5. polk audio coaxials
    By polkaudiosupra101 in forum Car Audio & Electronics
    Replies: 2
    Last Post: 11-28-2001, 02:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts