Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 9 of 9

Thread: PSW404 hum

  1. #1

    Member Sales Rating: (0)

    Join Date
    May 2006
    Location
    NE Wisconsin
    Posts
    2

    Unhappy PSW404 hum

    Hi Guys,
    I've had a PSW404 for about 5 months (to go with the SurroundBar) and just recently moved into a house where the room that contains the sub is much more quiet (as long as the kids are asleep). Now I notice an audible and annoying hum from as close as 10 feet away while nothing is plugged in except the power cord for the sub. I've tried other outlets and the thing still hums away. The sub otherwise works when a souce is applied. Incidentally, my big SVS in my home theater hums a small amount too but you've got to put your ear literally on the sub to hear it. Any thoughts? Thanks a bunch!

    Jim

  2. #2

    Member Sales Rating: (13)

    Join Date
    Mar 2002
    Location
    The Mars Hotel
    Posts
    30,432

    Default

    It doesn't seem like a ground loop issue, so it could be a case of dirty power being supplied to your new house. You might want to try a product like the PS Audio UPC-200 Humbuster, which helps clean up dirty power and helps with transformer hum issues.
    'Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end."

  3. #3

    Member Sales Rating: (2)

    Join Date
    Jun 2003
    Location
    Long Island, NY
    Posts
    2,098

    Default

    My 404 has a very low hum to it. Others don't hear it but I do.
    Last edited by Mike682; 05-13-2006 at 11:30 PM.
    Receiver: harmankardon AVR235
    Mains: polk R30
    Center: polk CSi3
    Rear Surrounds: polk R20
    Subwoofer: polk PSW404
    DVD: Panasonic DVD-S29

  4. #4

    Member Sales Rating: (2)

    Join Date
    Sep 2001
    Posts
    6,245

    Default

    Mine did to, its either normal as others has noticed it or its a warranty issue.. I would call KEN at polk CS and ask to be sure.
    MY HT RIG:
    Sherwood p-965
    Sherwood sd871 dvd
    Rotel 1075 amp x5
    LSI15 mains
    LsiC center
    LSIfx surround backs
    Lsi7 side surrounds
    SVS pb12/plus2


    2 Channel Rig:

    nad 1020 Pre-amp
    Rotel 1080 stereo amp
    Polk sda 2B
    kenwood grunt Tuner
    realistic lab 450 TT
    Signal cable IC

  5. #5

    Member Sales Rating: (0)

    Join Date
    May 2004
    Location
    Poughkeepsie, NY
    Posts
    623

    Default

    Twice so far on my 404, strain on the cable has made it hum. Haven't figured out whether it is the sub or the cable. But both times, just unplugging and replugging the cable to relieve the strain, has worked.

  6. #6

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    You most likely need to send the amplifier in for service, not purchase something else.

    polkcs@polkaudio.com

  7. #7

    Member Sales Rating: (0)

    Join Date
    May 2006
    Location
    NE Wisconsin
    Posts
    2

    Default

    Thanks for all the input, guys. You really can hear it from half-way across the room when the TV is off; my wife has confirmed this in case my ears were ringing. I've even tried several outlets via a 50ft. extension cord all over the place but still hum (again with nothing else connected except power). I would think if it was dirty power, at least something would be detectable on my other systems (whole house in-walls, home theater, computers x3, etc.) but I guess you never know for sure. So, how do I contact Ken? Does he check this board during only on weekdays? Thx.

  8. #8

    Member Sales Rating: (0)

    Join Date
    May 2006
    Location
    Naptown
    Posts
    20

    Default

    I think it's humming because it's bored. Blast some breakcore on that puppy and tell me if you can hear any humming

  9. #9

    Member Sales Rating: (58)

    Join Date
    Feb 2003
    Location
    6 Underground
    Posts
    25,306

    Default

    Any of the hardcore CS folks are more than able to help you @ 800-377-7655

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. HELP! low freq hum on the sub
    By ohskigod in forum Subwoofer Hookup & Bass Management
    Replies: 6
    Last Post: 04-08-2006, 10:06 PM
  2. New amp now a hum.
    By Skynut in forum Troubleshooting
    Replies: 25
    Last Post: 01-17-2006, 08:18 PM
  3. hum ... hum ... and more hum
    By bamamusicfan in forum Troubleshooting
    Replies: 3
    Last Post: 10-03-2004, 12:02 PM
  4. couldnt be happier psw404
    By rainman in forum Subwoofer Hookup & Bass Management
    Replies: 1
    Last Post: 07-21-2003, 10:20 PM
  5. These Effin Tweeters !will! !die!
    By MxStYlEpOlKmAn in forum Troubleshooting
    Replies: 13
    Last Post: 03-11-2003, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts