Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Member Sales Rating: (0)

    Join Date
    Sep 2004
    Posts
    330

    Default Bad eclipse amp?

    Hey guys, my kenwood 4 channel amp that Ive had for 11 years just died. My roommate had a older eclipse 4 channel amp that has been sitting in his closet for probably 4 years that he gave me. I have an Eclipse 8061 deck with the 8v/16v outputs & I have the gains on the eclipse amp all the way down. Im having problems with the channels cutting in & out & the only way to make them stop is to touch the crossover switches on the amp with a screwdriver. Now my question is, do you think that the switches are oxidized from sitting in a closet & for so long and a little cleaning might help it or do you think the amp is just bad now?

  2. #2

    Member Sales Rating: (0)

    Join Date
    May 2004
    Location
    San Diego, Ca
    Posts
    2,093

    Default

    I would try moving the knobs all the way to either side several times to see if that helps. You could take it apart to see if it's possible to clean those connections.

    Sometimes my detachable monitors do not work properly. The picture is not visible, or it's wavy. I will then take an alcohol moistened swab and clean the pin connections on both the monitors and the bracket. After doing this all is well.

    If all else fail call Eclipse to see how much they will charge you to repair it. May not be that much at all.
    Alpine: CDA-7949
    Alpine: PXA-H600
    Alpine: CHA-S624, KCA-420i, KCA-410C
    Rainbow: CS 265 Profi Phase Plug / SL 165
    ARC Audio: 4150-XXK / 1500v1-XXK
    JL Audio: 10W6v2 (x2)
    KnuKonceptz
    Second Skin

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. AMP and SUB wiring questions...
    By iLLz in forum Car Audio & Electronics
    Replies: 2
    Last Post: 08-08-2005, 01:26 AM
  2. B&K ST1400M Series II Amp
    By kingtut in forum Electronics
    Replies: 3
    Last Post: 09-10-2004, 12:53 PM
  3. Newbie needs amp advice!
    By iluvmusic in forum Electronics
    Replies: 15
    Last Post: 06-22-2004, 10:20 AM
  4. Audiosource Amp 3
    By kingtut in forum Electronics
    Replies: 4
    Last Post: 10-16-2003, 01:14 PM
  5. Good amp for 6 speaker system?--2 coax front, 4 coax rear
    By Dave Mancuso in forum Car Audio & Electronics
    Replies: 4
    Last Post: 10-13-2003, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts