Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    Member Sales Rating: (0)

    Join Date
    Oct 2006
    Posts
    2

    Unhappy Subwoofer not turning itself on?

    I have a PSW10, that I bought about a year ago. I can't get it to recieve any signal, using multiple amps, is there something special that I need to do with the switches?

    The subwoofer sends are initalized on the amp, but I can't get the red light to turn on, no matter what setting the "off/auto/on" switch is set to. I've even tested different plugs in my house hoping it was just something that needed to be switched on...

    Please help >.<

  2. #2

    Member Sales Rating: (1)

    Join Date
    Apr 2005
    Location
    Patterson Cali.
    Posts
    3,251

    Default

    My svs has a red light while on standby and green when it sees a signal.
    If I send a weak signal then the amp does not come on, more volume and it comes on.

    If you are getting nothing at all maybe there is a fuse blown.
    Maybe the interconnect has gone bad.

    not real sure but I assume it used to work for you so have you changed anything in your system or did it just stop working.
    Skynut
    SOPAŽ Founder
    The system Almost there
    DVD Onkyo DV-SP802
    Sunfire Theater Grand II
    Sherbourn 7/2100
    Panamax 5510 power conditioner (for electronics)
    2 PSAudio UPC-200 power conditioners (for amps)
    Front L/R RT3000p (Bi-Wired)
    Center CS1000p (Bi-Wired) (under the television)
    Center RT2000p's (Bi-Wired) (on each side of the television)
    Sur FX1000
    SVS ultra plus 2

    www.ShadetreesMachineShop.com
    Thanks for looking

  3. #3

    Member Sales Rating: (0)

    Join Date
    Oct 2006
    Posts
    2

    Default

    I just get no light, no matter how much strength is sent through the channel. It did work before- is there a fuse inside the psw10? I suppose I could check that.

  4. #4

    Member Sales Rating: (0)

    Join Date
    Jun 2007
    Posts
    1

    Default

    Sorry to bring back this thread from the dead. But my psw10 blew a fuse and I am trying to get a replacement. I know it is a 250V but what amperage is it? the only other marking on it is 5S2A. Tahnks any help would be appreciated.

    Jon

  5. #5
     Moderator 
    Member Sales Rating: (0)

    Join Date
    Jul 2001
    Location
    Polk Audio
    Posts
    3,842

    Default

    Hello,
    It is a 2.0 Ampere time delay fuse that is 5mm x 20mm.
    Regards, Ken

  6. #6

    Member Sales Rating: (0)

    Join Date
    Dec 2008
    Posts
    2

    Unhappy Where do I get the fuse

    I have the same problem and my sub is less than a year old. So where do I get this 5S2A 250V 2.0 Ampere time delay fuse that is 5mm x 20mm? I've been to hardware stores and Radio Shack without luck.

    I still love my Polk speakers.

    Ken

  7. #7

    Member Sales Rating: (1)

    Join Date
    Oct 2007
    Location
    NE PA
    Posts
    1,486

    Default

    I would let Ken give the final answer on this, but if I'm not mistaken the 5mm x 20mm fuse is very common and I don't think that the 250v 2 amp time delay should be too dificult to find. I think the Ratshack salesman you talked to may have been new. Also if I'm not mistaken the "time delay" is the same as "slow blow" maybe ask Ratshack for a "5mm x 20mm 250v 2 amp slow blow" fuse will give you better results.

  8. #8

    Member Sales Rating: (0)

    Join Date
    Dec 2008
    Posts
    2

    Default

    Thanks apphd. I'll keep trying.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. RM 6800 Subwoofer
    By keppy in forum Basic Hookup/Wiring Questions
    Replies: 4
    Last Post: 07-31-2006, 02:31 PM
  2. Replies: 9
    Last Post: 05-20-2006, 11:32 AM
  3. RM6800 Subwoofer / Onkyp TX603 Setup
    By MLZ in forum Subwoofer Hookup & Bass Management
    Replies: 5
    Last Post: 01-15-2006, 01:44 AM
  4. My SVS PB10-ISD Help?
    By Vegaspolka in forum Subwoofer Hookup & Bass Management
    Replies: 10
    Last Post: 12-14-2004, 02:28 PM
  5. DVD Subwoofer Preamp Output Works Better?
    By monkeyphant in forum Subwoofer Hookup & Bass Management
    Replies: 11
    Last Post: 08-29-2003, 10:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts