Free Shipping on All Orders 1-866-764-1801

Vist our Online Store
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Member Sales Rating: (3)

    Join Date
    Apr 2005
    Location
    Miami, FL
    Posts
    279

    Default Trouble Shooting LSiC One speaker no sound

    New LSiC

    Seemed fine at first.

    Then the volume seemed lower than it should have. i took the cover off the speakers, and sound is only coming from the right one and tweeter.

    What should be my course of action?

    I rechecked cables from amp to speaker and rebinded on the lower binding post.

    Still the same thing.

    What part of the speaker should i start looking for trouble shooting?

    I saw 4 screws around the binding post that i was going to try first, but wanted to get some opinions here first.

    thanks.

    -Matti
    Click here To see My system
    Polk LSI15,LSiC, LsiFX, SVS PB-12 Plus/2, Blue Jean Cables,Onkyo Pro PR-SC885P, Earthquake CinÚnova Grande
    Samsung HL-S6187W 61" DLP HDTV 1080P

  2. #2

    Member Sales Rating: (7)

    Join Date
    Aug 2004
    Location
    Central Illinois
    Posts
    5,247

    Default

    Here is a start

    And another

    And another

    And another

    And another


    And another

    long story short - I think you are fine.

    Michael
    Last edited by McLoki; 02-15-2007 at 09:25 PM.
    Mains.............Polk LSi15 (Cherry)
    Center............Polk LSiC (Crossover upgraded)
    Surrounds.......Polk LSi7 (Gloss Black - wood sides removed and crossovers upgraded)
    Subwoofers.....SVS 25-31 CS+ and PC+ (both 20hz tune)
    Pre\Pro...........NAD T163 (Modded with LM4562 opamps)
    Amplifier.........Cinepro 3k6 (6-channel, 500wpc@4ohms)

  3. #3

    Member Sales Rating: (3)

    Join Date
    Apr 2005
    Location
    Miami, FL
    Posts
    279

    Default

    Thanks MCLoki....

    I owe ya a beer :-)

    I have my cross over set to 90hz so that only leaves 90-200hz for the other woofer.

    going to set the center to large since it only gets voices etc...

    Cant wait, i have been holding off watching alot of movies till i have a full 3.1 setup.

    star wars, lotr, matrix, etc...
    Click here To see My system
    Polk LSI15,LSiC, LsiFX, SVS PB-12 Plus/2, Blue Jean Cables,Onkyo Pro PR-SC885P, Earthquake CinÚnova Grande
    Samsung HL-S6187W 61" DLP HDTV 1080P

  4. #4

    Member Sales Rating: (7)

    Join Date
    Aug 2004
    Location
    Central Illinois
    Posts
    5,247

    Default

    Personally I would still cross it over at 60 to 80hz, especially considering the sub you have... :) Go ahead and test both ways and see what you like though.

    Michael
    Mains.............Polk LSi15 (Cherry)
    Center............Polk LSiC (Crossover upgraded)
    Surrounds.......Polk LSi7 (Gloss Black - wood sides removed and crossovers upgraded)
    Subwoofers.....SVS 25-31 CS+ and PC+ (both 20hz tune)
    Pre\Pro...........NAD T163 (Modded with LM4562 opamps)
    Amplifier.........Cinepro 3k6 (6-channel, 500wpc@4ohms)

  5. #5

    Member Sales Rating: (3)

    Join Date
    Apr 2005
    Location
    Miami, FL
    Posts
    279

    Default

    i was under the impression that the better sub you have the higher you want your cross over to be.. so that the subwoofer can take over those frequencies...

    I will mess around with the settings and cross over at 60 70 and 80.

    Also is there a way that i can limit what my main speakers get and let the sub get even what the speakers are getting?
    Click here To see My system
    Polk LSI15,LSiC, LsiFX, SVS PB-12 Plus/2, Blue Jean Cables,Onkyo Pro PR-SC885P, Earthquake CinÚnova Grande
    Samsung HL-S6187W 61" DLP HDTV 1080P

  6. #6

    Member Sales Rating: (1)

    Join Date
    Jul 2001
    Location
    chicago
    Posts
    16,026

    Default

    You can limit the fronts thru your crossover settings,but you want the sub to come in where your other speakers leave off.By giveing your sub more than you should,it will sound localized and boomy.Go with Mcloki's advice on your settings.

  7. #7

    Member Sales Rating: (3)

    Join Date
    Apr 2005
    Location
    Miami, FL
    Posts
    279

    Default

    Plan for this weekend is LOTR movie series..

    Try crossover settings at 60,70,80 and see how it sounds :-P
    Click here To see My system
    Polk LSI15,LSiC, LsiFX, SVS PB-12 Plus/2, Blue Jean Cables,Onkyo Pro PR-SC885P, Earthquake CinÚnova Grande
    Samsung HL-S6187W 61" DLP HDTV 1080P

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. LSIC #2 driver no sound
    By johnnym in forum Troubleshooting
    Replies: 13
    Last Post: 08-02-2007, 03:45 PM
  2. lsic center has no sound from 1 speaker
    By betternot in forum Speakers
    Replies: 2
    Last Post: 02-11-2006, 10:08 AM
  3. Trouble shooting RM1300
    By joro514 in forum Troubleshooting
    Replies: 1
    Last Post: 04-05-2005, 10:32 AM
  4. Trouble Shooting Subwoofer Help??
    By Keane in forum Troubleshooting
    Replies: 1
    Last Post: 02-12-2005, 06:41 PM
  5. Replies: 3
    Last Post: 07-01-2002, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts